maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Osipov (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (SCM-518) wrong model in vss-settings.mdo works only with a bug in Modello 1.0-alpha-21 but not with Modello 1.0+
Date Mon, 13 Aug 2018 21:19:00 GMT

     [ https://issues.apache.org/jira/browse/SCM-518?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Michael Osipov updated SCM-518:
-------------------------------
    Fix Version/s: 1.10.1

> wrong model in vss-settings.mdo works only with a bug in Modello 1.0-alpha-21 but not
with Modello 1.0+
> -------------------------------------------------------------------------------------------------------
>
>                 Key: SCM-518
>                 URL: https://issues.apache.org/jira/browse/SCM-518
>             Project: Maven SCM
>          Issue Type: Bug
>          Components: maven-scm-provider-vss
>    Affects Versions: 1.2
>            Reporter: Hervé Boutemy
>            Assignee: Michael Osipov
>            Priority: Major
>             Fix For: 1.10.1
>
>
> after [documentation|http://maven.apache.org/scm/vss.html], vss-settings.xml file content
is 
> {code:xml}<vss-settings>
>   <Settings>
>     <vssDirectory>ss_exe_directory</vssDirectory>
>   </Settings>
> </vss-settings>
> {code}
> but actual vss-settings.mdo does not define "Settings" field.
> Reading such a file works only because of a bug in Modello parsing: MODELLO-152, which
has been fixed in Modello 1.0.
> There are 2 options for us: either change the documentation (and tell the users) to support
following model (which was the initial intend IMHO):
> {code:xml}<vss-settings>
>   <vssDirectory>ss_exe_directory</vssDirectory>
> </vss-settings>
> {code}
> or tweak the model and update the code to create an intermediate class for this Settings
element (only useful to avoid changing the XML format)



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message