maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karl Heinz Marbaise (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (MPOM-186) Upgrade several plugins to most recent versions for JDK9/10 Support
Date Thu, 28 Jun 2018 08:23:00 GMT

     [ https://issues.apache.org/jira/browse/MPOM-186?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Karl Heinz Marbaise updated MPOM-186:
-------------------------------------
    Description: 
* maven-clean-plugin 3.1.0
* maven-compiler-plugin 3.7.0
* maven-dependency-plugin 3.1.1
* maven-invoker-plugin 3.1.0
* maven-javadoc-plugin 3.0.1
* maven-resources-plugin 3.1.0
* maven-scm-publish-plugin 3.0.0
* maven-war-plugin 3.2.2
* maven-shade-plugin 3.1.1
* maven-surefire/failsafe 2.22.0
* maven-plugin-plugin 3.5.2
 * maven-project-info-reports-plugin 3.0.0

This would imply to lift the minimum JRE torun Maven to JRE 7. This is related to plugins
which are require minimum JDK 7 instead of JDK 6.

Several projects are already upgrading different plugins to get the running with JDK9/JDK10
(for example surefire) and others as well. Furthermore [security related things |http://maven.apache.org/security-plexus-archiver.html]

  was:
* maven-clean-plugin 3.1.0
* maven-compiler-plugin 3.7.0
* maven-dependency-plugin 3.1.1
* maven-invoker-plugin 3.1.0
* maven-javadoc-plugin 3.0.1
* maven-resources-plugin 3.1.0
* maven-scm-publish-plugin 3.0.0
* maven-war-plugin 3.2.2
* maven-shade-plugin 3.1.1
* maven-surefire/failsafe 2.22.0
* maven-plugin-plugin 3.5.2
 * maven-project-info-report-plugin 3.0.0

This would imply to lift the minimum JRE torun Maven to JRE 7. This is related to plugins
which are require minimum JDK 7 instead of JDK 6.

Several projects are already upgrading different plugins to get the running with JDK9/JDK10
(for example surefire) and others as well. Furthermore [security related things |http://maven.apache.org/security-plexus-archiver.html]


> Upgrade several plugins to most recent versions for JDK9/10 Support
> -------------------------------------------------------------------
>
>                 Key: MPOM-186
>                 URL: https://issues.apache.org/jira/browse/MPOM-186
>             Project: Maven POMs
>          Issue Type: Improvement
>    Affects Versions: ASF-20
>            Reporter: Karl Heinz Marbaise
>            Assignee: Karl Heinz Marbaise
>            Priority: Minor
>             Fix For: ASF-20
>
>
> * maven-clean-plugin 3.1.0
> * maven-compiler-plugin 3.7.0
> * maven-dependency-plugin 3.1.1
> * maven-invoker-plugin 3.1.0
> * maven-javadoc-plugin 3.0.1
> * maven-resources-plugin 3.1.0
> * maven-scm-publish-plugin 3.0.0
> * maven-war-plugin 3.2.2
> * maven-shade-plugin 3.1.1
> * maven-surefire/failsafe 2.22.0
> * maven-plugin-plugin 3.5.2
>  * maven-project-info-reports-plugin 3.0.0
> This would imply to lift the minimum JRE torun Maven to JRE 7. This is related to plugins
which are require minimum JDK 7 instead of JDK 6.
> Several projects are already upgrading different plugins to get the running with JDK9/JDK10
(for example surefire) and others as well. Furthermore [security related things |http://maven.apache.org/security-plexus-archiver.html]



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message