maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Scholte (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (MENFORCER-268) Usage of CI friendly version placeholders does not work
Date Mon, 11 Jun 2018 20:47:00 GMT

     [ https://issues.apache.org/jira/browse/MENFORCER-268?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Robert Scholte updated MENFORCER-268:
-------------------------------------
    Fix Version/s: 3.0.0-M2

> Usage of CI friendly version placeholders does not work
> -------------------------------------------------------
>
>                 Key: MENFORCER-268
>                 URL: https://issues.apache.org/jira/browse/MENFORCER-268
>             Project: Maven Enforcer Plugin
>          Issue Type: Bug
>    Affects Versions: 1.4.1, 3.0.0-M1
>            Reporter: Karl Heinz Marbaise
>            Assignee: Karl Heinz Marbaise
>            Priority: Blocker
>             Fix For: 3.0.0-M2, 3.0.0
>
>
> If I use the placeholders in a project based on the [CI Friendly|http://maven.apache.org/maven-ci-friendly.html]
currently maven-enforcer-plugin fails like this:
> {code}
> [INFO] --- flatten-maven-plugin:1.0.0:clean (flatten.clean) @ domain ---
> [INFO] Deleting /Users/kama/ws-git/javaee/domain/.flattened-pom.xml
> [INFO]
> [INFO] --- maven-enforcer-plugin:1.4.1:enforce (enforce-maven) @ domain ---
> Downloading: http://localhost:8081/nexus/content/groups/public/com/soebes/examples/j2ee/parent/$%7Brevision%7D$%7Bsha1%7D$%7Bchangelist%7D/parent-$%7Brevision%7D$%7Bsha1%7D$%7Bchangelist%7D.pom
> [WARNING] Rule 3: org.apache.maven.plugins.enforcer.RequireNoRepositories failed with
message:
> Could not find artifact com.soebes.examples.j2ee:parent:pom:${revision}${sha1}${changelist}
in nexus (http://localhost:8081/nexus/content/groups/public)
>   com.soebes.examples.j2ee:parent:pom:${revision}${sha1}${changelist}
> from the specified remote repositories:
>   nexus (http://localhost:8081/nexus/content/groups/public, releases=true, snapshots=true)
> [WARNING] Rule 4: org.apache.maven.plugins.enforcer.RequirePluginVersions failed with
message:
> Failure to find com.soebes.examples.j2ee:parent:pom:${revision}${sha1}${changelist} in
http://localhost:8081/nexus/content/groups/public was cached in the local repository, resolution
will not be reattempted until the update interval of nexus has elapsed or updates are forced
>   com.soebes.examples.j2ee:parent:pom:${revision}${sha1}${changelist}
> from the specified remote repositories:
>   nexus (http://localhost:8081/nexus/content/groups/public, releases=true, snapshots=true)
> {code}
> This is currently based on reading the pom file itself instead of using the parts which
are offered via Maven Core...



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message