maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Osipov (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (MNG-6416) Parallel Build with option "-T 1C" fails on Maven 3.5.3 + Linux Centos + Jenkins
Date Thu, 24 May 2018 19:58:00 GMT

    [ https://issues.apache.org/jira/browse/MNG-6416?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16489688#comment-16489688
] 

Michael Osipov edited comment on MNG-6416 at 5/24/18 7:57 PM:
--------------------------------------------------------------

So you took the time to write such a long report, but have nothing attached like a log file
or a sample project and you now expect us to fix that?


was (Author: michael-o):
So you took the time to write such a long report, but have nothing attached like a log file
or a sample project aund you now expect us to fix that?

> Parallel Build with option "-T 1C" fails on Maven 3.5.3 + Linux Centos + Jenkins
> --------------------------------------------------------------------------------
>
>                 Key: MNG-6416
>                 URL: https://issues.apache.org/jira/browse/MNG-6416
>             Project: Maven
>          Issue Type: Bug
>          Components: Bootstrap &amp; Build, Performance
>    Affects Versions: 3.5.3
>         Environment: Linux Centos
>            Reporter: Samir Shaik
>            Priority: Major
>
> +*Environment*+
> *OS:* Linux Centos
> *CI/CD Tool:* Jenkins
> *Maven:* 3.5.3
> *Model:* multi module project
> With Maven version 3.5.0 we were having issues with metadata.xml being wrongly updated
by Maven on Nexus3. So we upgraded to 3.5.3 to resolve the issue around metadata.xml issue.
With 3.5.3 we are unable to run parallel builds with "-T 1C" option.
> Note that the same setup works smooth on my local machine which has Windows 7 OS. This
has to do something with Maven3.5.3 + Linux + Jenkins. Would appreciate if you can take a
look and get to the root cause of this issue. We are ready to provide more details if that
helps.
>  
> *Expected behavior:* Build would run successfully.
> *Actual Behavior:* Build fails every time with different reasons. Ran build 4 times and
the results are attached to this ticket



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message