maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Adam Voss (JIRA)" <j...@apache.org>
Subject [jira] [Created] (MSITE-823) Documentation says JDK 1.6 required, doxia dependency requires 1.7
Date Wed, 09 May 2018 00:24:00 GMT
Adam Voss created MSITE-823:
-------------------------------

             Summary: Documentation says JDK 1.6 required, doxia dependency requires 1.7
                 Key: MSITE-823
                 URL: https://issues.apache.org/jira/browse/MSITE-823
             Project: Maven Site Plugin
          Issue Type: Bug
          Components: documentation
    Affects Versions: 3.7.1, 3.7
            Reporter: Adam Voss


[https://maven.apache.org/plugins/maven-site-plugin/plugin-info.html] lists System Requirements:

|JDK|1.6|

 

However doxia 1.8 is referenced, which requires JDK 1.7

As a result Java 6 builds will fail after updating to 3.7 or newer

{quote}
Caused by: java.lang.UnsupportedClassVersionError: org/apache/maven/doxia/module/markdown/MarkdownParserModule
: Unsupported major.minor version 51.0 
{quote}



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message