maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Scholte (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MCOMPILER-335) Update default source/target
Date Sat, 26 May 2018 07:29:00 GMT

    [ https://issues.apache.org/jira/browse/MCOMPILER-335?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16491554#comment-16491554
] 

Robert Scholte commented on MCOMPILER-335:
------------------------------------------

I didn't mean dropping the value. source+target or release must be required parameters as they
are right now, otherwise the results depend on the JDK version, that's not what I want. I'd
prefer not to change the value, it is good enough to make a "Hello World" application. Developers
should be motivated to always set this value, in case somebody decides in the future to change
the default value (again). But _if_ we do, then go for the lowest version supported by the
highest JDK. That would mean 1.6.

> Update default source/target
> ----------------------------
>
>                 Key: MCOMPILER-335
>                 URL: https://issues.apache.org/jira/browse/MCOMPILER-335
>             Project: Maven Compiler Plugin
>          Issue Type: Improvement
>    Affects Versions: 3.7.0
>            Reporter: Fred Bricon
>            Priority: Major
>
> default source/target have been set to 1.5 in 2010 (MCOMPILER-80). I think it's about
time to update the default.
> 1.8 would be my preference, as 9 /10 would probably be a tad too ambitious.
> But, since Maven requires at least Java 1.7 to run, 1.7 is probably the safest option.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message