maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tibor Digana (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SUREFIRE-1255) Surefire 2.19.1 hangs before starting test execution
Date Tue, 01 May 2018 20:09:00 GMT

    [ https://issues.apache.org/jira/browse/SUREFIRE-1255?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16460086#comment-16460086
] 

Tibor Digana commented on SUREFIRE-1255:
----------------------------------------

[~Abel S.Romero]
I am also using {{asciidoctor-maven-plugin}} with old version because when I tried to use
the to notch version the asciidoc to HTML/PDF hanged with high CPU.
The point of good investigating the issues is the style of separating influences. Isolate
them so that they are unplugged and combine them step by step. I do not see your project but
I doubt the Maven plugins are influenced. Maven 3+ properly isolated them with isolated ClassLoader-s.

> Surefire 2.19.1 hangs before starting test execution
> ----------------------------------------------------
>
>                 Key: SUREFIRE-1255
>                 URL: https://issues.apache.org/jira/browse/SUREFIRE-1255
>             Project: Maven Surefire
>          Issue Type: Bug
>          Components: Maven Surefire Plugin, process forking
>    Affects Versions: 2.19.1
>            Reporter: Maximilian Michels
>            Assignee: Tibor Digana
>            Priority: Critical
>
> Seeing the same error as SUREFIRE-1193 in Apache Flink builds after upgrading from 2.18.1
to 2.19.1. No errors, builds just gets stuck at the beginning of tests with no log output
from the test itself, e.g. https://s3.amazonaws.com/archive.travis-ci.org/jobs/137118454/log.txt
> After a couple of minutes Surefire reports 
> {noformat}
> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-surefire-plugin:2.19.1:test
(integration-tests) on project flink-scala-shell_2.10: ExecutionException The forked VM terminated
without properly saying goodbye. VM crash or System.exit called?
> [ERROR] Command was /bin/sh -c cd /home/travis/build/mxm/flink/flink-scala-shell/target
&& /usr/lib/jvm/java-8-oracle/jre/bin/java -Xms256m -Xmx800m -Dmvn.forkNumber=1 -XX:-UseGCOverheadLimit
-jar /home/travis/build/mxm/flink/flink-scala-shell/target/surefire/surefirebooter372520169616801479.jar
/home/travis/build/mxm/flink/flink-scala-shell/target/surefire/surefire8229439069544382018tmp
/home/travis/build/mxm/flink/flink-scala-shell/target/surefire/surefire_26373613144387982724tmp
> [ERROR] -> [Help 1]
> {noformat}
> We have a a couple of test classes that suffer from this problem. Tests don't read from
STDIN or replace it. Switching back to 2.18.1 eliminates the problem (Ran over 100 builds).
It seems to be a race condition because it only occurs every once in a while, i.e. ~ 2 out
of 10 builds on Travis. I haven't been able to reproduce the problem locally.
> More logs: https://s3.amazonaws.com/flink-logs-us/travis-artifacts/mxm/flink/849/849.1.tar.gz



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message