maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ivan Belis (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (MPH-142) mvn 3.0.5 starts using maven-help-plugin 3.0 resulting in java 6 problems
Date Fri, 23 Mar 2018 08:12:00 GMT

     [ https://issues.apache.org/jira/browse/MPH-142?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ivan Belis updated MPH-142:
---------------------------
    Attachment: image-2018-03-23-09-11-10-237.png

> mvn 3.0.5 starts using maven-help-plugin 3.0 resulting in java 6 problems
> -------------------------------------------------------------------------
>
>                 Key: MPH-142
>                 URL: https://issues.apache.org/jira/browse/MPH-142
>             Project: Maven Help Plugin
>          Issue Type: Bug
>    Affects Versions: 3.0.0
>         Environment: mvn -v
> Apache Maven 3.0.5 (r01de14724cdef164cd33c7c8c2fe155faf9602da; 2013-02-19 14:51:28+0100)
> Maven home: C:\devenv\java\apache-maven-3.0.5\bin\..
> Java version: 1.6.0_45, vendor: Sun Microsystems Inc.
>            Reporter: Ivan Belis
>            Priority: Major
>         Attachments: image-2018-03-23-09-11-10-237.png
>
>
> We are using maven 3.0.5 with a JDK 1.6.
> We did not change anything in our projects poms, but suddenly builds started failing
(multiple builds).
> This version of maven started using the 3.0.0 version of the help-plugin, resulting in
failing builds because the 3.0.0 does not support java 6.
>  
> REMARK: this is not a problem of the maven-help-plugin but rather a problem with how
maven determines the versions of plugins !
>  
> This is the error we are getting:
> WARNING: Error injecting: org.apache.maven.plugins.help.ActiveProfilesMojo
>  java.lang.TypeNotPresentException: Type org.apache.maven.plugins.help.ActiveProfilesMojo
not present
>          at org.sonatype.guice.bean.reflect.URLClassSpace.loadClass(URLClassSpace.java:109)
>          at org.sonatype.guice.bean.reflect.NamedClass.load(NamedClass.java:45)
> Caused by: java.lang.UnsupportedClassVersionError: org/apache/maven/plugins/help/ActiveProfilesMojo
: Unsupported major.minor version 51.0
>          at java.lang.ClassLoader.defineClass1(Native Method)
>          at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
>          at java.lang.ClassLoader.defineClass(ClassLoader.java:615)
>          at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
>  
> [ERROR] -----------------------------------------------------
>  [ERROR] realm =    plugin>org.apache.maven.plugins:maven-help-plugin:3.0.0
>  [ERROR] strategy = org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy
>  [ERROR] urls[0] = [file:/c:/devenv/java/.m2/repository/org/apache/maven/plugins/maven-help-plugin/3.0.0/maven-help-plugin-3.0.0.jar|file:///c:/devenv/java/.m2/repository/org/apache/maven/plugins/maven-help-plugin/3.0.0/maven-help-plugin-3.0.0.jar]
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message