maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ian Young (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (MJAVADOC-517) NPE under Java 10 EA
Date Wed, 07 Mar 2018 17:14:01 GMT

     [ https://issues.apache.org/jira/browse/MJAVADOC-517?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ian Young updated MJAVADOC-517:
-------------------------------
    Description: 
Under Java 10 EA, the plugin generates the following exception:
{code:java}
Caused by: java.lang.NullPointerException
    at org.apache.commons.lang3.SystemUtils.isJavaVersionAtLeast (SystemUtils.java:1626)
    at org.apache.maven.plugins.javadoc.AbstractJavadocMojo.getJavadocExecutable (AbstractJavadocMojo.java:3683)
    at org.apache.maven.plugins.javadoc.AbstractJavadocMojo.executeReport (AbstractJavadocMojo.java:2001)
    at org.apache.maven.plugins.javadoc.JavadocJar.doExecute (JavadocJar.java:190)
{code}
This seems to be down to the version string:
{code:java}
java version "10" 2018-03-20
Java(TM) SE Runtime Environment 18.3 (build 10+43)
Java HotSpot(TM) 64-Bit Server VM 18.3 (build 10+43, mixed mode)
{code}
{{commons-lang3}} version 3.5 can't deal with this, see https://issues.apache.org/jira/browse/LANG-1365 

Inserting an explicit dependency on {{commons-lang3}} version 3.7 for the plugin works round
the issue, and changing the dependency seems like the right fix for the next release of this
plugin.

  was:
Under Java 10 EA, the plugin generates the following exception:
{code:java}
Caused by: java.lang.NullPointerException
    at org.apache.commons.lang3.SystemUtils.isJavaVersionAtLeast (SystemUtils.java:1626)
    at org.apache.maven.plugins.javadoc.AbstractJavadocMojo.getJavadocExecutable (AbstractJavadocMojo.java:3683)
    at org.apache.maven.plugins.javadoc.AbstractJavadocMojo.executeReport (AbstractJavadocMojo.java:2001)
    at org.apache.maven.plugins.javadoc.JavadocJar.doExecute (JavadocJar.java:190)
{code}
This seems to be down to the version string:
{code:java}
java version "10" 2018-03-20
Java(TM) SE Runtime Environment 18.3 (build 10+43)
Java HotSpot(TM) 64-Bit Server VM 18.3 (build 10+43, mixed mode)
{code}
{{commons-lang3}} version 3.5 can't deal with this, see https://issues.apache.org/jira/browse/LANG-1365 

Inserting an explicit dependency on {{commons-lang3}} version 3.7 for the plugin works round
the issue, and seems the right fix for the next release of this plugin.


> NPE under Java 10 EA
> --------------------
>
>                 Key: MJAVADOC-517
>                 URL: https://issues.apache.org/jira/browse/MJAVADOC-517
>             Project: Maven Javadoc Plugin
>          Issue Type: Bug
>    Affects Versions: 3.0.0
>            Reporter: Ian Young
>            Priority: Major
>
> Under Java 10 EA, the plugin generates the following exception:
> {code:java}
> Caused by: java.lang.NullPointerException
>     at org.apache.commons.lang3.SystemUtils.isJavaVersionAtLeast (SystemUtils.java:1626)
>     at org.apache.maven.plugins.javadoc.AbstractJavadocMojo.getJavadocExecutable (AbstractJavadocMojo.java:3683)
>     at org.apache.maven.plugins.javadoc.AbstractJavadocMojo.executeReport (AbstractJavadocMojo.java:2001)
>     at org.apache.maven.plugins.javadoc.JavadocJar.doExecute (JavadocJar.java:190)
> {code}
> This seems to be down to the version string:
> {code:java}
> java version "10" 2018-03-20
> Java(TM) SE Runtime Environment 18.3 (build 10+43)
> Java HotSpot(TM) 64-Bit Server VM 18.3 (build 10+43, mixed mode)
> {code}
> {{commons-lang3}} version 3.5 can't deal with this, see https://issues.apache.org/jira/browse/LANG-1365 
> Inserting an explicit dependency on {{commons-lang3}} version 3.7 for the plugin works
round the issue, and changing the dependency seems like the right fix for the next release
of this plugin.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message