maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Osipov (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (MNG-5511) Can't override a profile setting in a plugin's dependency
Date Fri, 16 Mar 2018 22:40:14 GMT

     [ https://issues.apache.org/jira/browse/MNG-5511?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Michael Osipov closed MNG-5511.
-------------------------------
    Resolution: Auto Closed

This issue has been auto closed because it has been inactive for a long period of time. If
you think this issue still applies, retest your problem with the most recent version of Maven
and the affected component, reopen and post your results.

> Can't override a profile setting in a plugin's dependency
> ---------------------------------------------------------
>
>                 Key: MNG-5511
>                 URL: https://issues.apache.org/jira/browse/MNG-5511
>             Project: Maven
>          Issue Type: Bug
>          Components: Dependencies
>    Affects Versions: 3.0.4
>         Environment: OS X 10.8.3
>            Reporter: redcoat
>            Priority: Major
>
> We are trying to use the mojo cobertura plugin in our project.  However, it won't run
on my Mac Book Pro (OS X, 10.8.3) as Apple very kindly decided to move tools.jar and embed
it into classes.jar in a completely different directory.
> The plugin depends on cobertura, which defines the following property in its mac profile:
>     <profile>
>       <id>OSXProfile</id>
>       <activation>
>         <os>
>           <family>mac</family>
>         </os>
>       </activation>
>       <properties>
>         <toolsjar>${java.home}/../lib/tools.jar</toolsjar>
>       </properties>
>     </profile>
> and the accompanying dependency:
>     <dependency>
>       <groupId>com.sun</groupId>
>       <artifactId>tools</artifactId>
>       <version>0</version>
>       <scope>system</scope>
>       <systemPath>${toolsjar}</systemPath>
>     </dependency>
> This is wrong for Mac OS 10.8.3 running Java 6 on two counts - the lib directory is at
${java.home}/lib and the tools.jar doesn't exist in the lib directory as apple decided to
put those clases in ${java.home}/../Classes/classes.jar.
> I therefore need to be able to override the <toolsjar> setting, but nothing I've
tried works.  
> I have tried adding my own profile and setting <toolsjar> appropriately, but it
seems to be ignored.  I also tried specifying it on the command line, and again, it complains
it can't find ../lib/tools.jar.
> This is a show-stopper for us.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message