maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Roberto Benedetti (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MSITE-810) HTML code not injected in generated <head> element
Date Fri, 09 Feb 2018 17:40:00 GMT

    [ https://issues.apache.org/jira/browse/MSITE-810?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16358750#comment-16358750
] 

Roberto Benedetti commented on MSITE-810:
-----------------------------------------

The issue was due to a custom skin based on the retired stylus skin, which can't handle script
tags wrapped in CDATA.

It would be nice if the plugin could warn about old/incompatible skins.

> HTML code not injected in generated <head> element
> --------------------------------------------------
>
>                 Key: MSITE-810
>                 URL: https://issues.apache.org/jira/browse/MSITE-810
>             Project: Maven Site Plugin
>          Issue Type: Bug
>          Components: documentation, site:deploy
>    Affects Versions: 3.6, 3.7
>         Environment: Windows 7 64 bit
> Java 1.7.0_161
> Maven 3.5.2
> maven-site-plugin 3.6 or 3.7
>            Reporter: Roberto Benedetti
>            Priority: Blocker
>              Labels: documentation
>
> According to [documentation|https://maven.apache.org/plugins/maven-site-plugin/examples/sitedescriptor.html#Inject_xhtml_into_.3Chead.3E]
a script can be injected into generated <head> element adding it to /project/body/head
element of site descriptor.
> It worked fine with versions up to version 3.4.
> I tried to upgrade to version 3.6 and 3.7 and it does not work
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message