maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Scholte (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (MCOMPILER-315) "Older projects with module-info" documentation does not work
Date Sat, 24 Feb 2018 18:35:00 GMT

     [ https://issues.apache.org/jira/browse/MCOMPILER-315?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Robert Scholte closed MCOMPILER-315.
------------------------------------
    Resolution: Not A Problem
      Assignee: Robert Scholte

Closing this unless somebody provides a PR with the required documentation changes.

> "Older projects with module-info" documentation does not work
> -------------------------------------------------------------
>
>                 Key: MCOMPILER-315
>                 URL: https://issues.apache.org/jira/browse/MCOMPILER-315
>             Project: Maven Compiler Plugin
>          Issue Type: Bug
>    Affects Versions: 3.7.0
>            Reporter: Keir
>            Assignee: Robert Scholte
>            Priority: Major
>         Attachments: pom.xml
>
>
> I copied and pasted the 2nd snipped from https://maven.apache.org/plugins/maven-compiler-plugin/examples/module-info.html
, amending it to refer to Java 8 rather than 6, however the jar produced by mvn package is
still only consumable by Java 9 as all classes appear to have been compiled to its version.
Is there something else I need to do to get this to work? If so, the documentation could be
clearer. Or have I misunderstood something? I have attached the pom in question.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message