maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Victor Martinez (JIRA)" <j...@apache.org>
Subject [jira] [Created] (MRELEASE-992) Deprecated maven flag --no-plugin-updates shows warnings in the console output
Date Tue, 28 Nov 2017 12:10:00 GMT
Victor Martinez created MRELEASE-992:
----------------------------------------

             Summary: Deprecated maven flag --no-plugin-updates shows warnings in the console
output
                 Key: MRELEASE-992
                 URL: https://issues.apache.org/jira/browse/MRELEASE-992
             Project: Maven Release Plugin
          Issue Type: Improvement
          Components: prepare
    Affects Versions: 2.5.3
            Reporter: Victor Martinez
            Priority: Minor


Hi there,

It seems some maven flags have been deprecated since Maven 3.0 (see MNG-4697) and still used
by the maven-release plugin (see [here|https://github.com/apache/maven-release/blob/4ce69b81b9230f294338a5875ca1cf9333664808/maven-release-manager/src/main/java/org/apache/maven/shared/release/exec/ForkedMavenExecutor.java#L127]
which caused some warning output:

{code}
[WARNING] Command line option -npu is deprecated and will be removed in future Maven versions.
{code}

Just wondering whether it makes sense to get rid of that particular flag within the maven-release
plugin or just kept as a backward compatibility feature?

Thanks 



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message