maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ernst Reissner (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (MSITE-803) checkstyle version 8.4 not accessible.
Date Sun, 19 Nov 2017 18:08:00 GMT

     [ https://issues.apache.org/jira/browse/MSITE-803?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ernst Reissner updated MSITE-803:
---------------------------------
    Environment:     (was: One may use checkstyle plugin for various versions of checkstyle
e.g. 8.4 
specifying 

	    <dependency>
	      <groupId>com.puppycrawl.tools</groupId>
	      <artifactId>checkstyle</artifactId>
	      <version>8.4</version>
	    </dependency>

e.g. in the pluginManagement. 

In contrast, it is not possible to specify this in the reporting section. 

As a workaround, i would prefer adding a checkstyleVersion property 
in the configuration. 
Not that by default the plugin used checkstyle 6.11.2 
whereas the current is 8.4. 
)

> checkstyle version 8.4 not accessible. 
> ---------------------------------------
>
>                 Key: MSITE-803
>                 URL: https://issues.apache.org/jira/browse/MSITE-803
>             Project: Maven Site Plugin
>          Issue Type: Wish
>            Reporter: Ernst Reissner
>
>      One may use checkstyle plugin for various versions of checkstyle e.g. 8.4
>     specifying
>     <dependency>
>     <groupId>com.puppycrawl.tools</groupId>
>     <artifactId>checkstyle</artifactId>
>     <version>8.4</version>
>     </dependency>
>     e.g. in the pluginManagement.
>     In contrast, it is not possible to specify this in the reporting section.
>     As a workaround, i would prefer adding a checkstyleVersion property
>     in the configuration.
>     Not that by default the plugin used checkstyle 6.11.2
>     whereas the current is 8.4.
> Description



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message