maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Catalin Crihan (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (MWAR-408) <webXml> is not doing anything. web.xml still the default one regardless of the value of the attribute
Date Thu, 06 Jul 2017 07:10:00 GMT

     [ https://issues.apache.org/jira/browse/MWAR-408?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Catalin Crihan updated MWAR-408:
--------------------------------
    Description: 
I try to set a custom web.xml to my war-file by using the following configuration:
<plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-war-plugin</artifactId>
                <version>3.1.0</version>                
                <configuration>
                    <failOnMissingWebXml>true</failOnMissingWebXml>          
         
                    <configuration>                      
                        <webXml>${basedir}/target/web.xml</webXml>
                    </configuration>
                </configuration>
            </plugin>

The setting: "<webXml>${basedir}/target/web.xml</webXml>" seems to have no function
whatsoever. Regardless of the value I use the result is the same, even if the file is not
existent the plugin gives no warning, at least. The plugin generates its default web.xml and
this is it all.

  was:
I try to set a custom web.xml to my war-file by using the following configuration:
<plugin>
                <groupId>org.apache.maven.plugins</groupId>
                <artifactId>maven-war-plugin</artifactId>
                <version>3.1.0</version>                
                <configuration>
                    <failOnMissingWebXml>true</failOnMissingWebXml>          
         
                    <configuration>                      
                        <webXml>${basedir}/target/web.xml</webXml>
                    </configuration>
                </configuration>
            </plugin>

The setting: "<webXml*>${basedir}/target/web.xml</webXml>" seems to have no function
whatsoever. Regardless of the value I use the result is the same, even if the file is not
existent the plugin gives no warning, at least. The plugin generates its default web.xml and
this is it all.


> <webXml> is not doing anything. web.xml still the default one regardless of the
value of the attribute
> ------------------------------------------------------------------------------------------------------
>
>                 Key: MWAR-408
>                 URL: https://issues.apache.org/jira/browse/MWAR-408
>             Project: Maven WAR Plugin
>          Issue Type: Bug
>          Components: filtering
>    Affects Versions: 3.1.0
>         Environment: Maven 3.5, Netbeans 8.2, Java8
>            Reporter: Catalin Crihan
>
> I try to set a custom web.xml to my war-file by using the following configuration:
> <plugin>
>                 <groupId>org.apache.maven.plugins</groupId>
>                 <artifactId>maven-war-plugin</artifactId>
>                 <version>3.1.0</version>                
>                 <configuration>
>                     <failOnMissingWebXml>true</failOnMissingWebXml>     
              
>                     <configuration>                      
>                         <webXml>${basedir}/target/web.xml</webXml>
>                     </configuration>
>                 </configuration>
>             </plugin>
> The setting: "<webXml>${basedir}/target/web.xml</webXml>" seems to have no
function whatsoever. Regardless of the value I use the result is the same, even if the file
is not existent the plugin gives no warning, at least. The plugin generates its default web.xml
and this is it all.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message