maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Osipov (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (DOXIASITETOOLS-177) Use of commons-lang 2 causes failure with JDK 9 b175+
Date Tue, 04 Jul 2017 19:52:01 GMT

     [ https://issues.apache.org/jira/browse/DOXIASITETOOLS-177?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Michael Osipov closed DOXIASITETOOLS-177.
-----------------------------------------
    Resolution: Fixed

Fixed with [r1800812|http://svn.apache.org/r1800812].

> Use of commons-lang 2 causes failure with JDK 9 b175+
> -----------------------------------------------------
>
>                 Key: DOXIASITETOOLS-177
>                 URL: https://issues.apache.org/jira/browse/DOXIASITETOOLS-177
>             Project: Maven Doxia Sitetools
>          Issue Type: Bug
>          Components: Site renderer
>    Affects Versions: 1.7.4
>            Reporter: Anthony Vanelverdinghe
>            Assignee: Michael Osipov
>             Fix For: 1.7.5
>
>
> When doing a release of a Maven project, I get the stacktrace below. Since JDK 9 b175,
the java.version system property is simply "9". However, Doxia depends on commons-lang 2.4,
which assumes java.version has at least 3 characters.
> 	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:181)
> 	... 21 more
> Caused by: java.lang.ExceptionInInitializerError
> 	at org.apache.maven.doxia.siterenderer.DefaultSiteRenderer.generateDocument(DefaultSiteRenderer.java:732)
> 	at org.apache.maven.plugins.site.render.ReportDocumentRenderer.renderDocument(ReportDocumentRenderer.java:268)
> 	at org.apache.maven.doxia.siterenderer.DefaultSiteRenderer.render(DefaultSiteRenderer.java:337)
> 	at org.apache.maven.plugins.site.render.SiteMojo.renderLocale(SiteMojo.java:178)
> 	at org.apache.maven.plugins.site.render.SiteMojo.execute(SiteMojo.java:132)
> 	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:134)
> 	... 21 more
> Caused by: java.lang.StringIndexOutOfBoundsException: begin 0, end 3, length 1
> 	at java.base/java.lang.String.checkBoundsBeginEnd(String.java:3116)
> 	at java.base/java.lang.String.substring(String.java:1885)
> 	at org.apache.commons.lang.SystemUtils.getJavaVersionAsFloat(SystemUtils.java:1133)
> 	at org.apache.commons.lang.SystemUtils.<clinit>(SystemUtils.java:818)
> 	... 27 more



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message