maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Enrico Olivelli (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SUREFIRE-1265) reuseForks=false fails on jdk-9-ea builds
Date Wed, 03 May 2017 08:52:04 GMT

    [ https://issues.apache.org/jira/browse/SUREFIRE-1265?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15994486#comment-15994486
] 

Enrico Olivelli commented on SUREFIRE-1265:
-------------------------------------------

Thank you [~tibor17]
Is the test case good for you in order to see the failure ?
Otherwise I will try to add a test case to surefire-1265

IMHO This will be enough 
{code}
public class J9Test {

    @Test
    public void test_sql_mod() throws java.sql.SQLException {
        System.out.println(System.getProperty("java.specification.version"));
    }

    @Test
    public void test_corba_mod() /*throws org.omg.CORBA.BAD_INV_ORDER*/ {
    }

    @Test
    public void test_javaws()  {
        javax.xml.ws.Holder<String> holder = new javax.xml.ws.Holder("test");
        holder.value = "test";
    }
}
{code}

is there any way to launch a single test (Surefire1265Java9IT) of the IT of surefire ? I am
using -Dtest=xxxx but it does not work, the architecture is quite complex, if you give me
some pointer I will come at speed to the problem


> reuseForks=false fails on jdk-9-ea builds
> -----------------------------------------
>
>                 Key: SUREFIRE-1265
>                 URL: https://issues.apache.org/jira/browse/SUREFIRE-1265
>             Project: Maven Surefire
>          Issue Type: Bug
>          Components: Maven Surefire Plugin
>    Affects Versions: 2.19.1
>            Reporter: Michael Musgrove
>            Assignee: Tibor Digana
>              Labels: jigsaw
>             Fix For: 2.20.1
>
>         Attachments: j9test.tar, Java9Example.zip
>
>
> When I run any surefire test (with reuseForks=false) that uses java.sql classes on recent
jdk-9 ea builds it fails with:
> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-surefire-plugin:2.19.1:test
(default-test) on project maven-surefire-plugin-example: Execution default-test of goal org.apache.maven.plugins:maven-surefire-plugin:2.19.1:test
failed: java.lang.NoClassDefFoundError: java/sql/SQLException: java.sql.SQLException ->
[Help 1]
> If I run it with reuseForks=true it works fine.
> This problem was introduced in jdk build 9-ea+122 (http://download.java.net/java/jdk9/changes/jdk-9+122.html)
when the jigsaw team addressed: 
>     d20279be77d9	8154189	Deprivilege java.sql and java.sql.rowset module



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message