maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Scholte (JIRA)" <j...@apache.org>
Subject [jira] [Created] (MINVOKER-216) Prepare for Java9 (requires Groovy upgrade)
Date Sun, 22 Jan 2017 14:55:27 GMT
Robert Scholte created MINVOKER-216:
---------------------------------------

             Summary: Prepare for Java9 (requires Groovy upgrade)
                 Key: MINVOKER-216
                 URL: https://issues.apache.org/jira/browse/MINVOKER-216
             Project: Maven Invoker Plugin
          Issue Type: Improvement
    Affects Versions: 2.0.0
            Reporter: Robert Scholte
            Assignee: Robert Scholte
             Fix For: 3.0.0


Running this plugin with Java9 works quite well, except there are issues with groovy which
is using some constructions which are not allowed anymore in Java9.
With Groovy these should all be fixed.

ps. One of the ITs depends on gmaven-plugin, which is not maintained anymore and won't work
with Java9. This one needs to be rewritten.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message