maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Chapin (JIRA)" <>
Subject [jira] [Commented] (MASSEMBLY-842) Incorrect entries created in MANIFEST/maven
Date Wed, 11 Jan 2017 06:38:58 GMT


John Chapin commented on MASSEMBLY-842:

FWIW, I experienced the same issue - it manifested as a failure to unzip jar files on AWS's
Lambda platform.

Downgrading the maven-assembly-plugin to version 2.6 solved this issue for me. I didn't make
any changes to the slf4j-api dependencies.

> Incorrect entries created in MANIFEST/maven
> -------------------------------------------
>                 Key: MASSEMBLY-842
>                 URL:
>             Project: Maven Assembly Plugin
>          Issue Type: Bug
>    Affects Versions: 3.0.0
>         Environment: Fedora 25
>            Reporter: Andreas Aronsson
>         Attachments:
> When executing 'mvn package' on the attached project, the produced archive(s) are not
produced as expected. As an example, the following entries in the zip archive I expect to
be marked as directories and end with a slash rather than the current state: 
> {noformat}
> crwsrwsrwx         0  11-Feb-2016  21:30:54  META-INF/maven/org.slf4j
> crwsrwsrwx         0  11-Feb-2016  21:30:54  META-INF/maven/org.slf4j/slf4j-api
> {noformat}
> In the tar archive they are links which is also not expected. 
> I have also tried to find any reference to this in maven-archiver and plexus-archiver
but wasn't able to find anything. 
> Using the {{unzip}} utility asks the following:
> {noformat}
> replace META-INF/maven? [y]es, [n]o, [A]ll, [N]one, [r]ename: 
> {noformat}
> during unzip which was also unexpected. 

This message was sent by Atlassian JIRA

View raw message