maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Viczai Gábor (JIRA) <j...@apache.org>
Subject [jira] [Updated] (DOXIA-551) tWiki anchor link generates page link
Date Sun, 08 Jan 2017 13:51:58 GMT

     [ https://issues.apache.org/jira/browse/DOXIA-551?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Viczai Gábor updated DOXIA-551:
-------------------------------
    Description: 
When generating site doc with maven plugin, html files generated from *.twiki files contains
wrong links for anchor links.

In twiki file if I specify [[#MyAnchor][a link]] it generates <a href="./#MyAnchor.html">a
link</a>
It seems like, no matter what, a ".html" is always inserted at the end of the link. (Possibly
the link is not recognised as an anchor?!)

(However, the anchor creation itself is ok. If a line starting with "#MyAnchor" in the twiki
file is present, the html output will contain the <a name="MyAnchor">...</a> at
the correct place.)

  was:
When generating site doc with maven plugin, html files generated from *.twiki files contains
wrong links for anchor links.

In twiki file if I specify <pre>[[#MyAnchor][a link]]</pre> it generates <a
href="./#MyAnchor.html">a link</a>
It seems like, no matter what, a ".html" is always inserted at the end of the link. (Possibly
the link is not recognised as an anchor?!)

(However, the anchor creation itself is ok. If a line starting with "#MyAnchor" in the twiki
file is present, the html output will contain the <a name="MyAnchor">...</a> at
the correct place.)


> tWiki anchor link generates page link
> -------------------------------------
>
>                 Key: DOXIA-551
>                 URL: https://issues.apache.org/jira/browse/DOXIA-551
>             Project: Maven Doxia
>          Issue Type: Bug
>          Components: Maven plugin
>    Affects Versions: 1.7
>         Environment: Linux
>            Reporter: Viczai Gábor
>            Priority: Minor
>              Labels: anchor, link, link-local, twiki
>
> When generating site doc with maven plugin, html files generated from *.twiki files contains
wrong links for anchor links.
> In twiki file if I specify [[#MyAnchor][a link]] it generates <a href="./#MyAnchor.html">a
link</a>
> It seems like, no matter what, a ".html" is always inserted at the end of the link. (Possibly
the link is not recognised as an anchor?!)
> (However, the anchor creation itself is ok. If a line starting with "#MyAnchor" in the
twiki file is present, the html output will contain the <a name="MyAnchor">...</a>
at the correct place.)



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message