maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karl Heinz Marbaise (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (MNG-6092) warn if prerequisites.maven used for non-plugin projects
Date Sat, 01 Oct 2016 14:49:22 GMT

     [ https://issues.apache.org/jira/browse/MNG-6092?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Karl Heinz Marbaise updated MNG-6092:
-------------------------------------
    Component/s: core

> warn if prerequisites.maven used for non-plugin projects
> --------------------------------------------------------
>
>                 Key: MNG-6092
>                 URL: https://issues.apache.org/jira/browse/MNG-6092
>             Project: Maven
>          Issue Type: Wish
>          Components: core
>    Affects Versions: 3.3.9
>            Reporter: Hervé Boutemy
>             Fix For: 3.4.0
>
>
> as seen in MNG'4840 and documented in MNG-5297, in Maven 3, prerequisites.maven has a
meaning for plugin projects: defining this for non-plugins projects makes feel that it will
be checked like it was done in Maven 2, but this is not the case.
> Adding a warning could help people avoid this habit taken with Maven 2



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message