maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alix Lourme (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (MPIR-349) Bad modules links in 'index/modules' reports when 'distributionManagement.site.url' comes from settings.xml
Date Thu, 29 Sep 2016 21:50:20 GMT

     [ https://issues.apache.org/jira/browse/MPIR-349?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Alix Lourme updated MPIR-349:
-----------------------------
    Summary: Bad modules links in 'index/modules' reports when 'distributionManagement.site.url'
comes from settings.xml  (was: Bad modules links in 'Index' report when 'distributionManagement.site.url'
comes from settings.xml)

> Bad modules links in 'index/modules' reports when 'distributionManagement.site.url' comes
from settings.xml
> -----------------------------------------------------------------------------------------------------------
>
>                 Key: MPIR-349
>                 URL: https://issues.apache.org/jira/browse/MPIR-349
>             Project: Maven Project Info Reports Plugin
>          Issue Type: Bug
>          Components: index, modules
>    Affects Versions: 2.9
>            Reporter: Alix Lourme
>              Labels: features
>             Fix For: 2.10
>
>         Attachments: MPIR-349-maven-project-info-reports-plugin.patch, variableSettingsIndexReport.zip
>
>
> When the _distributionManagement.site.url_ contains a property filled in _settings.xml_
like :
> _pom.xml_ :
> {code}
>     <distributionManagement>
>         <site>
>             <id>projectSite</id>
>             <url>${sitePublishLocation}/foo/${project.artifactId}</url>
>         </site>
>     </distributionManagement>
> {code}
> _settings.xml_:
> {code}
> <?xml version="1.0" encoding="ISO-8859-1"?>
> <settings ...>
>     <profiles>
>         <profile>
>             <id>site-location</id>
>             <properties>
>                 <sitePublishLocation>file://tmp/sitePublish</sitePublishLocation>
>             </properties>
>         </profile>
>     </profiles>
>     <activeProfiles>
>         <activeProfile>site-location</activeProfile>
>     </activeProfiles>
> </settings>
> {code}
> The modules links in *index* report contain
> {code}
> ${sitePublishLocation}
> {code}
> Problem can be reproduced with [^variableSettingsIndexReport.zip] project (dependencies
required : [maven-site-plugin 3.6-SNAPSHOT|http://svn.apache.org/repos/asf/maven/plugins/trunk/maven-site-plugin]
& [doxia-integration-tools 1.7.2-SNAPSHOT|https://svn.apache.org/repos/asf/maven/doxia/doxia-sitetools/trunk/]).
> This command fails:
> {code}
> mvn site -s settings-site-location.xml
> {code}
> This command works:
> {code}
> mvn site -s settings-site-location.xml -DsitePublishLocation="/tmp/sitePublish"
> {code}
> The root cause is explained in MSITE-783 and fixed by DOXIASITETOOLS-166.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message