maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Patrick (JIRA)" <j...@apache.org>
Subject [jira] [Created] (MGPG-58) Encrypted Passphrase in settings.xml fails
Date Thu, 08 Sep 2016 12:32:20 GMT
Robert Patrick created MGPG-58:
----------------------------------

             Summary: Encrypted Passphrase in settings.xml fails 
                 Key: MGPG-58
                 URL: https://issues.apache.org/jira/browse/MGPG-58
             Project: Maven GPG Plugin
          Issue Type: Bug
    Affects Versions: 1.6
            Reporter: Robert Patrick


I have my Maven build set up to automatically sign my artifacts and have everything working
perfectly when the settings.xml profile entry has the clear text passphrase.

If I use mvn --encrypt-password to generate an encrypted version of the passphrase and substitute
it for my clear-text passphrase, the gpg plugin fails with:

gpg: no default secret key: Bad passphrase
gpg: signing failed: Bad passphrase

My profile looks like this:

  <profiles>
    <profile>
      <id>ossrh</id>
      <activation>
        <activeByDefault>true</activeByDefault>
      </activation>
      <properties>
        <gpg.executable>gpg</gpg.executable>
        <gpg.passphrase>{rDYNQ7KHyZYHJogTS2ppwiLCu+ZJjJ4uEhsG8tLsadw=}</gpg.passphrase>
      </properties>
    </profile>
  </profiles>

Replacing the encrypted passphrase with the clear text one makes the build work again...



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message