maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "MoonFruit (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (MSHADE-226) Shade with location for IBM's Websphere Application Server load error
Date Sun, 12 Jun 2016 08:06:21 GMT

     [ https://issues.apache.org/jira/browse/MSHADE-226?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

MoonFruit updated MSHADE-226:
-----------------------------
    Environment: IBM's Websphere Application Server 8.5.5.9  (was: IBM's Websphere Application
Server)

> Shade with location for IBM's Websphere Application Server load error
> ---------------------------------------------------------------------
>
>                 Key: MSHADE-226
>                 URL: https://issues.apache.org/jira/browse/MSHADE-226
>             Project: Maven Shade Plugin
>          Issue Type: Bug
>    Affects Versions: 2.4.3
>         Environment: IBM's Websphere Application Server 8.5.5.9
>            Reporter: MoonFruit
>
> Mybatis 3.4.0 use shade to integrate javassist and ognl with relocation.
> But when deploy war which has mybatis-3.4.0.jar to IBM's Websphere Application Server
8.5.5.9, the war cannot start because of the relocation of javassist.
> Then I create a mybatis-3.4.0.jar without javassist and a independent javassist jar put
it to my war. And deploy it to IBM's Websphere Application Server 8.5.5.9, everything is right.
> So, I think maybe there is some error when shade plugin relocate javassist.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message