maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Utku Gultopu (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (MNG-6033) Maven plugin tutorial not working as expected?
Date Thu, 02 Jun 2016 21:05:59 GMT

     [ https://issues.apache.org/jira/browse/MNG-6033?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Utku Gultopu updated MNG-6033:
------------------------------
    Description: 
I am following the maven plugin [tutorial|https://maven.apache.org/guides/plugin/guide-java-plugin-development.html].

I have created the the <code>GreetingMojo</code> class and the POM as described
in the tutorial, and run <code>mvn install</code> but I am getting the same error
as indicated in <a href="http://stackoverflow.com/questions/18999401/basic-maven-plugin-project-not-working-mojo-plugin-descriptors-not-generating">this</a>
question (also by the issue <a href="https://issues.apache.org/jira/browse/MNG-5346">MNG-5346</a>).

<a href="http://maven.apache.org/docs/3.2.2/release-notes.html">3.2.2 release notes</a>
state that the issue is fixed. I have the 3.3.9 version of Maven. However, I still get:
<br/>
<code>org.apache.maven.plugin.descriptor.InvalidPluginDescriptorException: No mojo definitions
were found for plugin: sample.plugin:hello-maven-plugin</code>

Am I missing something here?

  was:
I am following the maven plugin [tutorial|https://maven.apache.org/guides/plugin/guide-java-plugin-development.html]

I have created the the <code>GreetingMojo</code> class and the POM as described
in the tutorial, and run <code>mvn install</code> but I am getting the same error
as indicated in <a href="http://stackoverflow.com/questions/18999401/basic-maven-plugin-project-not-working-mojo-plugin-descriptors-not-generating">this</a>
question (also by the issue <a href="https://issues.apache.org/jira/browse/MNG-5346">MNG-5346</a>).

<a href="http://maven.apache.org/docs/3.2.2/release-notes.html">3.2.2 release notes</a>
state that the issue is fixed. I have the 3.3.9 version of Maven. However, I still get:
<br/>
<code>org.apache.maven.plugin.descriptor.InvalidPluginDescriptorException: No mojo definitions
were found for plugin: sample.plugin:hello-maven-plugin</code>

Am I missing something here?


> Maven plugin tutorial not working as expected?
> ----------------------------------------------
>
>                 Key: MNG-6033
>                 URL: https://issues.apache.org/jira/browse/MNG-6033
>             Project: Maven
>          Issue Type: Question
>          Components: Documentation: Guides
>    Affects Versions: 3.3.9
>            Reporter: Utku Gultopu
>
> I am following the maven plugin [tutorial|https://maven.apache.org/guides/plugin/guide-java-plugin-development.html].
> I have created the the <code>GreetingMojo</code> class and the POM as described
in the tutorial, and run <code>mvn install</code> but I am getting the same error
as indicated in <a href="http://stackoverflow.com/questions/18999401/basic-maven-plugin-project-not-working-mojo-plugin-descriptors-not-generating">this</a>
question (also by the issue <a href="https://issues.apache.org/jira/browse/MNG-5346">MNG-5346</a>).
> <a href="http://maven.apache.org/docs/3.2.2/release-notes.html">3.2.2 release notes</a>
state that the issue is fixed. I have the 3.3.9 version of Maven. However, I still get:
> <br/>
> <code>org.apache.maven.plugin.descriptor.InvalidPluginDescriptorException: No mojo
definitions were found for plugin: sample.plugin:hello-maven-plugin</code>
> Am I missing something here?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message