maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thorsten Heit (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MJAR-222) when i upgrade 3.0.0 from 2.6, eclipse show org.apache.maven.archiver.MavenArchiver.getManifest(org.apache.maven.project.MavenProject, org.apache.maven.archiver.MavenArchiveConfiguration)
Date Fri, 20 May 2016 08:40:13 GMT

    [ https://issues.apache.org/jira/browse/MJAR-222?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15293012#comment-15293012
] 

Thorsten Heit commented on MJAR-222:
------------------------------------

I also saw this phenomenon. Reproducing the error is quite simple:

In Eclipse, create a new Maven project via the wizard, use the quickstart archetype, add m-jar-p
3.0.0 in the generated pom.xml, et voilĂ : Eclipse shows the above mentioned error.

Sample pom.xml:

{code:xml|title=Sample pom.xml}
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
	xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
	<modelVersion>4.0.0</modelVersion>

	<groupId>sample</groupId>
	<artifactId>project</artifactId>
	<version>0.0.1-SNAPSHOT</version>
	<packaging>jar</packaging>

	<name>project</name>
	<url>http://maven.apache.org</url>

	<properties>
		<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
	</properties>

	<build>
		<plugins>
			<plugin>
				<groupId>org.apache.maven.plugins</groupId>
				<artifactId>maven-jar-plugin</artifactId>
				<version>3.0.0</version>
			</plugin>
		</plugins>
	</build>

	<dependencies>
		<dependency>
			<groupId>junit</groupId>
			<artifactId>junit</artifactId>
			<version>3.8.1</version>
			<scope>test</scope>
		</dependency>
	</dependencies>
</project>
{code}

{code:java|title=Archetype-generated code in src/main/java/sample/project}
package sample.project;

/**
 * Hello world!
 *
 */
public class App 
{
    public static void main( String[] args )
    {
        System.out.println( "Hello World!" );
    }
}
{code}

If you change the plugin version back to 2.6, the error magically disappears...

Nevertheless, you can build the project from the command line without any errors.

> when i upgrade 3.0.0 from 2.6, eclipse show org.apache.maven.archiver.MavenArchiver.getManifest(org.apache.maven.project.MavenProject,
org.apache.maven.archiver.MavenArchiveConfiguration)
> -------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: MJAR-222
>                 URL: https://issues.apache.org/jira/browse/MJAR-222
>             Project: Maven JAR Plugin
>          Issue Type: Bug
>    Affects Versions: 3.0.0
>            Reporter: feilong
>
> when i upgrade <v.maven-jar-plugin>3.0.0</v.maven-jar-plugin> from 2.6
> in eclipse 
> org.apache.maven.archiver.MavenArchiver.getManifest(org.apache.maven.project.MavenProject,
org.apache.maven.archiver.MavenArchiveConfiguration)
> but project can mvn install
> my eclipse version is 4.5.2
> and when rollback maven-jar-plugin version to 2.6 ,and maven-->update project... ,everything
is ok
> about issue image,you can see my Comment  in
> http://blog.soebes.de/blog/2016/05/15/apache-maven-jar-plugin-version-3-dot-0-dot-0-released/#disqus_thread



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message