maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MWAR-369) Upgrade to XStream 1.4.9
Date Tue, 29 Mar 2016 17:43:25 GMT

    [ https://issues.apache.org/jira/browse/MWAR-369?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15216439#comment-15216439
] 

Hudson commented on MWAR-369:
-----------------------------

SUCCESS: Integrated in maven-plugins #5540 (See [https://builds.apache.org/job/maven-plugins/5540/])
[MWAR-369] Upgrade to 1.4.7 based on security issues. (khmarbaise: [http://svn.apache.org/viewvc/?view=rev&rev=1737023])
* maven-war-plugin/pom.xml


> Upgrade to XStream 1.4.9
> ------------------------
>
>                 Key: MWAR-369
>                 URL: https://issues.apache.org/jira/browse/MWAR-369
>             Project: Maven WAR Plugin
>          Issue Type: Bug
>          Components: manifest
>    Affects Versions: 2.6
>            Reporter: Mark Symons
>              Labels: security
>             Fix For: 3.0.0
>
>
> maven-war-plugin v2.6 has dependency on {{com.thoughtworks.xstream:xstream}} 1.4.4
> There are two security threats:
> * CVE-2013-7285, an arbitrary execution of commands when unmarshalling. Addressed in
1.4.7
> * XXE vulnerability, addressed in 1.4.9
>  CVE-2013-7285 is identified as an "unscored" threat by Nexus Repository Manager.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message