maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason W. Thompson (JIRA)" <j...@apache.org>
Subject [jira] [Created] (MDEP-521) Unpack goal fails in java versions earlier than 7
Date Tue, 01 Mar 2016 18:15:18 GMT
Jason W. Thompson created MDEP-521:
--------------------------------------

             Summary: Unpack goal fails in java versions earlier than 7
                 Key: MDEP-521
                 URL: https://issues.apache.org/jira/browse/MDEP-521
             Project: Maven Dependency Plugin
          Issue Type: Bug
          Components: unpack
    Affects Versions: 2.10
            Reporter: Jason W. Thompson


When using the unpack goal with Java 1.5 or 1.6, the following error message will appear:

{{\[ERROR\] Failed to execute goal org.apache.maven.plugins:maven-dependency-plugin:2.10:unpack
(unpack) on project ID-JRE_8.0: Execution unpack of goal org.apache.maven.plugins:maven-dependency-plugin:2.10:unpack
failed: An API incompatibility was encountered while executing org.apache.maven.plugins:maven-dependency-plugin:2.10:unpack:
java.lang.NoSuchMethodError: java.io.File.toPath()Ljava/nio/file/Path;}}

This is obviously calling a method introduced in Java 7. This contradicts the about page\[1\]
that indicates that JDK 1.5 is the minimum required.

This bug does not appear until version 2.10. Version 2.9 works fine.

\[1\] http://maven.apache.org/plugins-archives/maven-dependency-plugin-2.10/project-summary.html



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message