maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Hervé Boutemy (JIRA) <j...@apache.org>
Subject [jira] [Commented] (MPDF-78) Compatibility with doxia-module-docbook-simple 1.7
Date Mon, 29 Feb 2016 16:15:18 GMT

    [ https://issues.apache.org/jira/browse/MPDF-78?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15172073#comment-15172073
] 

Hervé Boutemy commented on MPDF-78:
-----------------------------------

yes, this was expected: we need to do a new release
did you try to use trunk and compile it for yourself, to confirm that it works for you as
expected?
I think I updated code when doing the changes, but I'm not sure integration tests are very
good: then having a real world check would be a good feedback

> Compatibility with doxia-module-docbook-simple 1.7
> --------------------------------------------------
>
>                 Key: MPDF-78
>                 URL: https://issues.apache.org/jira/browse/MPDF-78
>             Project: Maven PDF Plugin
>          Issue Type: Improvement
>    Affects Versions: 1.3
>            Reporter: Denis Braud
>
> maven-pdf-plugin 1.3 became incompatible with doxia-module-docbook-simple last version
(1.7).
> [ERROR] 1) Error in custom provider, java.lang.TypeNotPresentException: Type org.apache.maven.doxia.module.docbook.DocBookSiteModule
not present
> DocBookSiteModule has been removed in 1.7 :
> see https://issues.apache.org/jira/browse/DOXIA-511 : remove deprecated o.a.m.doxia.module.site
package (- DocBookSiteModule)
> pom Configuration :
> {code:xml}<plugin>
>   <artifactId>maven-pdf-plugin</artifactId>
>   <version>1.3</version>
>   <dependencies>
>     <dependency>
>       <groupId>org.apache.maven.doxia</groupId>
>       <artifactId>doxia-module-docbook-simple</artifactId>
>       <version>1.7</version>
>     </dependency>
>   </dependencies>
> </plugin>{code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message