maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "vishal sahasrabuddhe (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SCM-811) m2 release plugin shows SCM git password if fatal occured during git push
Date Tue, 05 Jan 2016 05:19:39 GMT

    [ https://issues.apache.org/jira/browse/SCM-811?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15082399#comment-15082399
] 

vishal sahasrabuddhe commented on SCM-811:
------------------------------------------

Hi, I am also facing similar issue with mvn release plugin (ticket was raised https://issues.apache.org/jira/browse/MRELEASE-937
)

I have added git authentication part in settings.xml like below.
{quote}
        <server>
            <id>git</id>
            <username>releasebot</username>
            <password>{AEfPhTGymJYHN+NQLTLwRU6SjUwaF6zB+uN/RsR/Qac=}</password>
        </server>
{quote}

And i am seeing following message 

Here is the log.
{noformat}
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 8.856 s (Wall Clock)
[INFO] Finished at: 2016-01-04T08:15:04+00:00
[INFO] Final Memory: 17M/484M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-release-plugin:2.5.3:prepare
(default-cli) on project qubole_python: Unable to commit files
[ERROR] Provider message:
[ERROR] The git-push command failed.
[ERROR] Command output:
[ERROR] remote: Not Found
[ERROR] fatal: repository 'https://releasebot:abc@123@gitlab.something.com/sandbox/data-ingestion-dco.git/'
not found
[ERROR] -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following
articles:
{noformat}
So, i can see password "abc@123" here.

I am using maven Apache Maven 3.3.9
tried with maven release plugin 2.5.3 and 2.5.2 both but no luck.

> m2 release plugin shows SCM git password if fatal occured during git push
> -------------------------------------------------------------------------
>
>                 Key: SCM-811
>                 URL: https://issues.apache.org/jira/browse/SCM-811
>             Project: Maven SCM
>          Issue Type: Improvement
>          Components: maven-scm-provider-git
>    Affects Versions: 1.9.4
>         Environment: RHEL6, Windows
>            Reporter: Vasilii Ruzov
>
> I'm running
> mvn release:prepare -Dusername=myuser -Dpassword=mypassword
> and see lines in output:
> {quote}[INFO] Executing: cmd.exe /X /C "git push https://myuser:********@myserver.com:8081/scm/project/project.git
refs/heads/master:refs/heads/master"
> {quote}
> but if for some reason git push failed(e.g. I made a mistake typing password) then I
see in log
> {quote}
> [ERROR] fatal: unable to access 'https://myuser:mypassword@myserver.com:8081/scm/project/project.git/':
SSL certificate problem: self signed certificate in certificate chain
> {quote}
> So I see *PLAINTEXT* password. As I use this step on Teamcity it causes security problems
when someone else can see my password if build failed. I tried both on Linux and Windows machines.
> I use maven-release-plugin version 2.5.3.
> http://stackoverflow.com/questions/33831383/maven-release-plugin-shows-plaintext-password-on-git-push-error



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message