maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Osipov (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MSHARED-430) Update JDK requirement to 1.6 / upgrade Maven Core dependencies to 3.0
Date Tue, 05 Jan 2016 00:08:40 GMT

    [ https://issues.apache.org/jira/browse/MSHARED-430?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15082052#comment-15082052
] 

Michael Osipov commented on MSHARED-430:
----------------------------------------

I think this change should be reverted. Hervé and I are preparing a new Doxia (Sitetools)
release still targeted to Maven 2.2.x (last one) and this components needs to comply with
it. I would recommend to downgrade to 2.5, etc.

> Update JDK requirement to 1.6 / upgrade Maven Core dependencies to 3.0
> ----------------------------------------------------------------------
>
>                 Key: MSHARED-430
>                 URL: https://issues.apache.org/jira/browse/MSHARED-430
>             Project: Maven Shared Components
>          Issue Type: Improvement
>          Components: maven-reporting-impl
>            Reporter: Robert Scholte
>            Assignee: Robert Scholte
>             Fix For: maven-reporting-impl 3.0
>
>
> When using maven-reporting-impl-2.x with Maven 3, it includes some Maven-2 dependencies,
since these artifactIds don't exist in Maven3 anymore, e.g maven-project (is now part of maven-core).
> Plugins are already moving forward, so this shared component should do so too.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message