maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Osipov (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (MANTRUN-177) Ant properties not passed to maven 3.0.4
Date Tue, 12 Jan 2016 20:12:45 GMT

     [ https://issues.apache.org/jira/browse/MANTRUN-177?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Michael Osipov closed MANTRUN-177.
----------------------------------
    Resolution: Auto Closed

This issue has been auto closed because it has been inactive for a long period of time. If
you think this issue still persists, retest your problem with the most recent version of Maven
and the affected component, reopen and post your results.

> Ant properties not passed to maven 3.0.4
> ----------------------------------------
>
>                 Key: MANTRUN-177
>                 URL: https://issues.apache.org/jira/browse/MANTRUN-177
>             Project: Maven Antrun Plugin
>          Issue Type: Bug
>    Affects Versions: 1.7
>         Environment: Apache Maven 3.0.4 (r1232337; 2012-01-17 01:44:56-0700)
> Java version: 1.6.0_34, vendor: Sun Microsystems Inc.
> Default locale: en_US, platform encoding: Cp1252
> OS name: "windows 7", version: "6.1", arch: "x86", family: "windows"
>            Reporter: Paul Gazda
>         Attachments: build.log, pom.xml_test
>
>
> I have a pom.xml that uses maven-antrun-plugin v 1.7 in phase "validate"
> to detect the run environment, and based on that set the appropriate
> filters file path as property "filters.file". exportAntProperties is set to
> true. The filters.file property is supposed to be used in the filters tag
> like this:
>   <build>
>       <filters>
>         <filter>${filters.file}</filter>
>       </filters>
>  .
>  .
>  .
> This worked when I was using maven 2.2.1, but since I upgraded to maven
> 3.0.4, the value for filters.file is no longer being passed to the <filter>
> tag.
> I have attached a test pom.xml I created to demonstrate the problem. If "mvn install"
is run with maven 2.2.1, the value for ${filters.file} is passed to maven (the install will
fail after this because it is a dummy test, but it is clear that the ${filters.file} value
has been passed correctly). If I run it with maven 3.0.4, the value for ${filters.file} is
not passed to maven. I have attached and the maven build log from the failed 3.0.4 "mvn install".



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message