maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Leventhal Arthen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MRELEASE-933) maven-release-plugin:perform from a tag is broken for Git in version 2.5.3
Date Mon, 14 Dec 2015 21:59:46 GMT

    [ https://issues.apache.org/jira/browse/MRELEASE-933?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15056793#comment-15056793
] 

Eric Leventhal Arthen commented on MRELEASE-933:
------------------------------------------------

In the scm section of the project pom we define: <tag>HEAD</tag>

When we do a release, we tell the build the tag set with the release:prepare.
Looking at both a build that succeeded with the older version of the plugin and the one that
failed with the newer version, I see that the build job had its system properties set as follows
(just substituting server and project names):

{code}
system.branchName	master
system.connectionUrl	scm:git:git@gitserver.company.com:aaaa/bbbb.git
system.tag	bbbb-3.0.4 
{code}

These have been working fine til now.


> maven-release-plugin:perform from a tag is broken for Git in version 2.5.3
> --------------------------------------------------------------------------
>
>                 Key: MRELEASE-933
>                 URL: https://issues.apache.org/jira/browse/MRELEASE-933
>             Project: Maven Release Plugin
>          Issue Type: Bug
>    Affects Versions: 2.5
>            Reporter: Eric Leventhal Arthen
>
> We are also blocked from using {{maven-release-plugin:2.5:perform}} for Git releases
because it no longer passes in the tag name so the "git clone" fails.
> This worked correctly in {{maven-release-plugin:2.3.2:perform}}, with that version we
got a command like this:
> {noformat}
>     git clone --branch my-base-1.4.6 git@bithub:abcde/fghij.git /home/buildacct/work/5f89075470257ef1/base/target/checkout
> {noformat}
> (Note that the name here is (correctly) a tag name created by release:prepare, even though
it is passed to --branch.)
> With {{maven-release-plugin:2.5:perform}} it does not include the actual tag name after
"--branch" so the command fails.
> {noformat}
>     git clone --branch git@bithub.brightcove.com:abcde/fghij.git /home/buildacct/work/7483cd6cc5ce81ea/target/checkout
>    [ERROR] The git-clone command failed.
> {noformat}
> We have to downgrade to the older maven-release-plugin, 2.3.2. From the ticket below
this also worked in 2.2.1. I have not tried other versions.
> Found a description of this problem in SCM-729 in a comment in Feb 2015, but are creating
this ticket because the issue is a recently introduced bug and that ticket is a feature request
for a different component.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message