maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jakub Bochenski (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (WAGON-405) Preemptive authentication still not working with Maven 3.0.4+
Date Wed, 23 Dec 2015 18:38:46 GMT

    [ https://issues.apache.org/jira/browse/WAGON-405?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15070021#comment-15070021
] 

Jakub Bochenski commented on WAGON-405:
---------------------------------------

I just wasted whole day trying to figure out why the example in documentation doesn't work
:(
Can someone with write access finally update the documentation?

> Preemptive authentication still not working with Maven 3.0.4+
> -------------------------------------------------------------
>
>                 Key: WAGON-405
>                 URL: https://issues.apache.org/jira/browse/WAGON-405
>             Project: Maven Wagon
>          Issue Type: Bug
>            Reporter: Konrad Windszus
>         Attachments: WAGON-405-MVN3.1.1.log
>
>
> Although by default the preemptive authentication should work now with Maven 3.0.4, a
wireshare dump exposes, that each request for downloading a new dependency does not initially
come with the authentication header. Only after  Nexus replied with a 401 the right credentials
are set in the authentication header. According to [1], since Maven 3.0.4 the default HTTP
wagon uses preemptive authentication which cannot be disabled [2]. Even with Maven 3.1.1 it
does not work.
> [1] - http://maven.apache.org/guides/mini/guide-http-settings.html#Maven_3.0.4
> [2] - http://maven.40175.n5.nabble.com/Maven-3-0-4-preemptive-auth-problem-tt5470892.html#none



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message