maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karl Heinz Marbaise (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MNG-5801) Unable to set webappDirectory
Date Sun, 08 Nov 2015 15:50:11 GMT

    [ https://issues.apache.org/jira/browse/MNG-5801?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14995683#comment-14995683
] 

Karl Heinz Marbaise commented on MNG-5801:
------------------------------------------

First this is not an issue of Maven it could be an issue of the maven-war-plugin. Apart from
that i would suggest to use up-to-date versions of the plugins and not such ancient versions.
Furthermore i would ask why do you need to change the location where the war is being built
independent of it's working or not...

> Unable to set webappDirectory
> -----------------------------
>
>                 Key: MNG-5801
>                 URL: https://issues.apache.org/jira/browse/MNG-5801
>             Project: Maven
>          Issue Type: Bug
>    Affects Versions: 2.2
>         Environment: Windows 7, Java 1.7.0_76
>            Reporter: Jochen Wiedmann
>         Attachments: demo.tar.gz, demoCleanInstall.log
>
>
> I've got a war project (see attached zip file), which contains the  configuration snippet
below. As a consequence, I'd expect the assembled webapp to be in {{target/my-webapp}}. However,
it is in {{target/demo-0.0.1-SNAPSHOT}}.
> {code:xml}
>   <build>
>     <plugins>
>       <plugin>
>         <groupId>org.apache.maven.plugin</groupId>
>         <artifactId>maven-war-plugin</artifactId>
>         <version>2.2</version>
>         <configuration>
>           <webappDirectory>${project.build.directory}/my-webapp</webappDirectory>
>         </configuration>
>       </plugin>
>     </plugins>
>   </build>
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message