maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karl Heinz Marbaise (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (MSOURCES-82) Make naming of properties consistent to the plugin name.
Date Tue, 29 Sep 2015 09:56:04 GMT

     [ https://issues.apache.org/jira/browse/MSOURCES-82?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Karl Heinz Marbaise updated MSOURCES-82:
----------------------------------------
    Description: 
Make the naming of the properties consistent to the plugin naming cause currently the properties
look like this:

{noformat}
 @Parameter( property = "attach", defaultValue = "true" )
 @Parameter( property = "source.excludeResources", defaultValue = "false" )
 @Parameter( property = "source.includePom", defaultValue = "false" )
 @Parameter( property = "source.forceCreation", defaultValue = "false" )
 @Parameter( property = "source.skip", defaultValue = "false" )
 @Parameter( property = "maven.source.classifier", defaultValue = "sources" )
 @Parameter( property = "maven.source.test.classifier", defaultValue = "test-sources" )
{noformat}


So it would be nice to change it to the following:

 * {{attach}} should be named {{maven.source.attach}}, 
 * {{source.excludeResources}} should be named {{maven.source.excludeResources}},
 * {{source.includePom}} should be named {{maven.source.includePom}}, 
 * {{source.forceCreation}} should be named {{maven.source.forceCreation}}, 
 * {{source.skip}} should be named {{maven.source.skip}}


  was:
Make the naming of the properties consistent to the plugin naming:

{{attach}} should be named {{maven.source.attach}}, {{source.excludeResources}} should be
named {{maven.source.excludeResources}}, {{source.includePom}} should be named {{maven.source.includePom}},
{{source.forceCreation}} should be named {{maven.source.forceCreation}}, {{source.skip}} should
be named {{maven.source.skip}}


> Make naming of properties consistent to the plugin name.
> --------------------------------------------------------
>
>                 Key: MSOURCES-82
>                 URL: https://issues.apache.org/jira/browse/MSOURCES-82
>             Project: Maven Source Plugin
>          Issue Type: Improvement
>    Affects Versions: 3.0.0
>            Reporter: Karl Heinz Marbaise
>            Priority: Minor
>             Fix For: 3.0.0
>
>
> Make the naming of the properties consistent to the plugin naming cause currently the
properties look like this:
> {noformat}
>  @Parameter( property = "attach", defaultValue = "true" )
>  @Parameter( property = "source.excludeResources", defaultValue = "false" )
>  @Parameter( property = "source.includePom", defaultValue = "false" )
>  @Parameter( property = "source.forceCreation", defaultValue = "false" )
>  @Parameter( property = "source.skip", defaultValue = "false" )
>  @Parameter( property = "maven.source.classifier", defaultValue = "sources" )
>  @Parameter( property = "maven.source.test.classifier", defaultValue = "test-sources"
)
> {noformat}
> So it would be nice to change it to the following:
>  * {{attach}} should be named {{maven.source.attach}}, 
>  * {{source.excludeResources}} should be named {{maven.source.excludeResources}},
>  * {{source.includePom}} should be named {{maven.source.includePom}}, 
>  * {{source.forceCreation}} should be named {{maven.source.forceCreation}}, 
>  * {{source.skip}} should be named {{maven.source.skip}}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message