maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SUREFIRE-1179) TestNG parallel options seem to not be honored
Date Sat, 26 Sep 2015 23:35:04 GMT

    [ https://issues.apache.org/jira/browse/SUREFIRE-1179?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14909524#comment-14909524
] 

ASF GitHub Bot commented on SUREFIRE-1179:
------------------------------------------

GitHub user Tibor17 opened a pull request:

    https://github.com/apache/maven-surefire/pull/106

    [SUREFIRE-1179] integration test

    for #105 

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/Tibor17/maven-surefire s4

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/maven-surefire/pull/106.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #106
    
----
commit 5ac824733ea4b8201e8acd5c1d6cead0301340ab
Author: Julien Herr <julien.herr@alcatel-lucent.com>
Date:   2015-09-18T14:19:10Z

    Quick fix for SUREFIRE-1177 and SUREFIRE-1179

commit 5105a84099af74d579d5975b25e1bdfe04333643
Author: Tibor17 <tibor17@lycos.com>
Date:   2015-09-26T23:18:12Z

    [SUREFIRE-1179] integration test

----


> TestNG parallel options seem to not be honored
> ----------------------------------------------
>
>                 Key: SUREFIRE-1179
>                 URL: https://issues.apache.org/jira/browse/SUREFIRE-1179
>             Project: Maven Surefire
>          Issue Type: Bug
>          Components: TestNG support
>    Affects Versions: 2.18.1
>         Environment: Windows 7 x64, Java 8 (1.8.0_60), TestNG v6.9.6, Maven Surefire
version 2.18.1
>            Reporter: Jeff Vincent
>            Assignee: Tibor Digana
>         Attachments: testng-test.zip
>
>
> I have some simple tests I'm trying to configure to run in parallel using Maven 3.3.3
and the latest versions of TestNG.  I've set my POM file to the following:
>              <plugin>
>                 <groupId>org.apache.maven.plugins</groupId>
>                 <artifactId>maven-surefire-plugin</artifactId>
>                 <version>2.18.1</version>
>                 <configuration>
>                     <parallel>methods</parallel>
>                     <threadCount>50</threadCount>
>                 </configuration>
>             </plugin>
> When I run in parallel, I only get 10 threads no matter the setting and I can not change
it.  I've tried adding the annotation parameter  to the method as well:
>      @Test(dataProvider = "dataProvider", threadPoolSize = 50)
> Nothing seems to help.  I have a simple project that illustrates what I'm seeing.  



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message