maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeff Vincent (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SUREFIRE-1179) TestNG parallel options seem to not be honored
Date Thu, 17 Sep 2015 17:33:05 GMT

    [ https://issues.apache.org/jira/browse/SUREFIRE-1179?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14803277#comment-14803277
] 

Jeff Vincent commented on SUREFIRE-1179:
----------------------------------------

TestNG discussion thread:  https://groups.google.com/forum/#!topic/testng-users/MkqmrrKDsVg

As for properties, if I'm reading it right I changed the POM to be:

{code:title=POM.XML snippet}
<plugin>
    <groupId>org.apache.maven.plugins</groupId>
    <artifactId>maven-surefire-plugin</artifactId>
    <version>2.18.1</version>
    <configuration>
        <properties>
            <property>
                <name>parallel</name>
                <value>methods</value>
            </property>
            <property>
                <name>dataproviderthreadcount</name>
                <value>13</value>
            </property>
        </properties>
    </configuration>
</plugin>
{code}

This is causing the following exception:
{code:title=Stack Trace}
Failed to execute goal org.apache.maven.plugins:maven-surefire-plugin:2.18.1:test (default-cli)
on project testng-test: Execution default-cli of goal org.apache.maven.plugins:maven-surefire-plugin:2.18.1:test
failed: There was an error in the forked process
java.lang.ClassCastException: java.lang.String cannot be cast to java.lang.Integer
at org.testng.TestNG.configure(TestNG.java:1535)
at org.apache.maven.surefire.testng.conf.TestNGMapConfigurator.configure(TestNGMapConfigurator.java:53)
at org.apache.maven.surefire.testng.TestNGExecutor.run(TestNGExecutor.java:113)
at org.apache.maven.surefire.testng.TestNGDirectoryTestSuite.executeSingleClass(TestNGDirectoryTestSuite.java:129)
at org.apache.maven.surefire.testng.TestNGDirectoryTestSuite.execute(TestNGDirectoryTestSuite.java:113)
at org.apache.maven.surefire.testng.TestNGProvider.invoke(TestNGProvider.java:111)
at org.apache.maven.surefire.booter.ForkedBooter.invokeProviderInSameClassLoader(ForkedBooter.java:203)
at org.apache.maven.surefire.booter.ForkedBooter.runSuitesInProcess(ForkedBooter.java:155)
at org.apache.maven.surefire.booter.ForkedBooter.main(ForkedBooter.java:103)
-> [Help 1]
{code}

> TestNG parallel options seem to not be honored
> ----------------------------------------------
>
>                 Key: SUREFIRE-1179
>                 URL: https://issues.apache.org/jira/browse/SUREFIRE-1179
>             Project: Maven Surefire
>          Issue Type: Bug
>          Components: TestNG support
>    Affects Versions: 2.18.1
>         Environment: Windows 7 x64, Java 8 (1.8.0_60), TestNG v6.9.6, Maven Surefire
version 2.18.1
>            Reporter: Jeff Vincent
>            Assignee: Tibor Digana
>         Attachments: testng-test.zip
>
>
> I have some simple tests I'm trying to configure to run in parallel using Maven 3.3.3
and the latest versions of TestNG.  I've set my POM file to the following:
>              <plugin>
>                 <groupId>org.apache.maven.plugins</groupId>
>                 <artifactId>maven-surefire-plugin</artifactId>
>                 <version>2.18.1</version>
>                 <configuration>
>                     <parallel>methods</parallel>
>                     <threadCount>50</threadCount>
>                 </configuration>
>             </plugin>
> When I run in parallel, I only get 10 threads no matter the setting and I can not change
it.  I've tried adding the annotation parameter  to the method as well:
>      @Test(dataProvider = "dataProvider", threadPoolSize = 50)
> Nothing seems to help.  I have a simple project that illustrates what I'm seeing.  



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message