maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeff Vincent (JIRA)" <>
Subject [jira] [Commented] (SUREFIRE-1179) TestNG parallel options seem to not be honored
Date Thu, 17 Sep 2015 15:53:04 GMT


Jeff Vincent commented on SUREFIRE-1179:

I'm currently posting on the testng-users mailing list to try and narrow this down.

In trying to run via the command-line, I noticed an option called 'dataproviderthreadcount'.
 Setting this resulted in the correct behavior I was expecting.

Now the question, can I somehow set this in the surefire plugin configuration?   I can't find
any documentation on it specifically.  In the maven-surefire-plugin source code I've seen
references to the 'new' way to set properties (see : line 262):

     * List of properties for configuring all TestNG related configurations. This is the new
preferred method of
     * configuring TestNG.
     * @since 2.4
    protected Properties properties;

But I'm unsure IF or HOW this translates to the POM configuration. 

> TestNG parallel options seem to not be honored
> ----------------------------------------------
>                 Key: SUREFIRE-1179
>                 URL:
>             Project: Maven Surefire
>          Issue Type: Bug
>          Components: TestNG support
>    Affects Versions: 2.18.1
>         Environment: Windows 7 x64, Java 8 (1.8.0_60), TestNG v6.9.6, Maven Surefire
version 2.18.1
>            Reporter: Jeff Vincent
>            Assignee: Tibor Digana
>         Attachments:
> I have some simple tests I'm trying to configure to run in parallel using Maven 3.3.3
and the latest versions of TestNG.  I've set my POM file to the following:
>              <plugin>
>                 <groupId>org.apache.maven.plugins</groupId>
>                 <artifactId>maven-surefire-plugin</artifactId>
>                 <version>2.18.1</version>
>                 <configuration>
>                     <parallel>methods</parallel>
>                     <threadCount>50</threadCount>
>                 </configuration>
>             </plugin>
> When I run in parallel, I only get 10 threads no matter the setting and I can not change
it.  I've tried adding the annotation parameter  to the method as well:
>      @Test(dataProvider = "dataProvider", threadPoolSize = 50)
> Nothing seems to help.  I have a simple project that illustrates what I'm seeing.  

This message was sent by Atlassian JIRA

View raw message