maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Loren Cole (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (MSHADE-204) Multiple JDBC drivers not supported
Date Wed, 02 Sep 2015 23:09:46 GMT

     [ https://issues.apache.org/jira/browse/MSHADE-204?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Loren Cole closed MSHADE-204.
-----------------------------
    Resolution: Not A Problem

Hey that's awesome, thank you!

<transformer implementation="org.apache.maven.plugins.shade.resource.ServicesResourceTransformer"/>

> Multiple JDBC drivers not supported
> -----------------------------------
>
>                 Key: MSHADE-204
>                 URL: https://issues.apache.org/jira/browse/MSHADE-204
>             Project: Maven Shade Plugin
>          Issue Type: Bug
>    Affects Versions: 2.4.1
>            Reporter: Loren Cole
>
> Mysql JDBC driver not working when building a project with dependencies on both postgres
and mysql JDBC drivers.
> java.sql.DriverManager uses the /META-INF/Services/java.sql.Driver to register available
JDBC drivers.  When doing a shaded build this file is overwritten with each driver, so the
last one wins.  Instead it should be appended to contain all available drivers.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message