maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karl Heinz Marbaise (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (MCLEAN-63) Make naming of properties consistent
Date Sat, 26 Sep 2015 11:05:04 GMT

     [ https://issues.apache.org/jira/browse/MCLEAN-63?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Karl Heinz Marbaise updated MCLEAN-63:
--------------------------------------
    Fix Version/s:     (was: 2.7)
                   3.0

> Make naming of properties consistent
> ------------------------------------
>
>                 Key: MCLEAN-63
>                 URL: https://issues.apache.org/jira/browse/MCLEAN-63
>             Project: Maven Clean Plugin
>          Issue Type: Improvement
>    Affects Versions: 2.6.1
>            Reporter: Karl Heinz Marbaise
>             Fix For: 3.0
>
>
> The list of properties looks like this:
> {code}
> @Parameter( property = "clean.verbose" )
> @Parameter( property = "clean.followSymLinks", defaultValue = "false" )
> @Parameter( property = "clean.skip", defaultValue = "false" )
> @Parameter( property = "maven.clean.failOnError", defaultValue = "true" )
> @Parameter( property = "maven.clean.retryOnError", defaultValue = "true" )
> @Parameter( property = "clean.excludeDefaultDirectories", defaultValue = "false" )
> {code}
> The property names should follow the naming convention: {{maven.PLUGIN.WhatEver}} So
 {{clean.verbose}} should be changed into {{maven.clean.verbose}}, {{clean.followSymLinks}}
should be changed into {{maven.clean.followSymLinks}}, {{clean.skip}} should be changed into
{{maven.clean.skip}}, and {{clean.excludeDefaultDirectories}} should be changed into {{maven.clean.excludeDefaultDirectories}}.
> The old properties {{clean.*}} should be marked deprecated and a WARNING should be emitted.
With version 3.X they can be replaced completely.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message