maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SUREFIRE-1144) Time for testsuite on commandline does not suit with the time value given in the report file
Date Mon, 28 Sep 2015 23:25:04 GMT

    [ https://issues.apache.org/jira/browse/SUREFIRE-1144?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14934329#comment-14934329
] 

ASF GitHub Bot commented on SUREFIRE-1144:
------------------------------------------

Github user lamyaa commented on the pull request:

    https://github.com/apache/maven-surefire/pull/96#issuecomment-143900518
  
    @Tibor17 I just tested this PR with your recent SUREFIRE-1144 fix. It still works. 
    Again, the point here was really just to provide the same level of information as the
console (which already shows individual times for each rerun). As for the time shown in the
test case, it could be the sum, the last time, or we could just leave it as it is currently
(the first run time).
    It's also fine to speak with Andreas first and get his take on this.


> Time for testsuite on commandline does not suit with the time value given in the report
file
> --------------------------------------------------------------------------------------------
>
>                 Key: SUREFIRE-1144
>                 URL: https://issues.apache.org/jira/browse/SUREFIRE-1144
>             Project: Maven Surefire
>          Issue Type: Bug
>          Components: Maven Surefire Plugin
>    Affects Versions: 2.18
>            Reporter: Karl Heinz Marbaise
>            Assignee: Tibor Digana
>            Priority: Critical
>             Fix For: 2.19
>
>         Attachments: mvn.log, surefire.reports.tar.gz
>
>
> Currently i have a build where i got printed out the following:
> {noformat}
> [INFO] --- maven-surefire-plugin:2.18:test (default-test) @ supose-cli ---
> [INFO] Surefire report directory: /Users/kama/ws-git/supose/supose-cli/target/surefire-reports
> -------------------------------------------------------
>  T E S T S
> -------------------------------------------------------
> Running com.soebes.supose.cli.SuposeCLITest
> Configuring TestNG with: TestNG652Configurator
> Tests run: 22, Failures: 0, Errors: 0, Skipped: 0, Time elapsed: 0.562 sec - in com.soebes.supose.cli.SuposeCLITest
> Results :
> Tests run: 22, Failures: 0, Errors: 0, Skipped: 0
> [INFO]
> {noformat}
> So if i take a look into the appropriate surefire-report file {{supose-cli/target/surefire-reports/TEST-com.soebes.supose.cli.SuposeCLITest.xml}}
i see the following in the first lines:
> {code:xml}
> <?xml version="1.0" encoding="UTF-8"?>
> <testsuite name="com.soebes.supose.cli.SuposeCLITest" time="0.142" tests="22" errors="0"
skipped="0" failures="0">
>   <properties>
> {code}
> which shows a complete different time {{0.142}} instead of {{0.562}}.
> I have had expected to see the same time in the xml file as well as on the print out
on console...
> So the question is: Where does this difference come frome? Do i misundestand a thing
here?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message