maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anthony Whitford (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (WAGON-413) Private Key authentication is no longer working with wagon-ssh-2.6
Date Thu, 28 May 2015 22:08:18 GMT

    [ https://issues.apache.org/jira/browse/WAGON-413?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14563776#comment-14563776
] 

Anthony Whitford commented on WAGON-413:
----------------------------------------

Since there is a patch, could this be scheduled for 2.10?

> Private Key authentication is no longer working with wagon-ssh-2.6
> ------------------------------------------------------------------
>
>                 Key: WAGON-413
>                 URL: https://issues.apache.org/jira/browse/WAGON-413
>             Project: Maven Wagon
>          Issue Type: Bug
>          Components: wagon-ssh
>    Affects Versions: 2.6
>         Environment: Windows, Maven 3.0.4, Java 7 64-bit
>            Reporter: Anthony Whitford
>            Priority: Blocker
>         Attachments: maven-wagon-ssh-WAGON-413.patch
>
>
> I have to provide the {{wagon-ssh}} dependency to the {{maven-site-plugin}} in order
to upload the site via {{scp}}.  Authentication for the {{scp}} is done via an _SSH key_.
> Version 2.5 works fine, but when I upgrade to version 2.6, I am now getting a Password
prompt, and then a _Connection Refused_.  (The Private Key should negate a password prompt.)
> With version 2.6, I get BUILD FAILURE:
> {noformat}
> [INFO] --- maven-site-plugin:3.3:deploy (default-deploy) @ project ---
>  Using private key: C:\Users\BuildAgent\.ssh\id_rsa
>  Password for buildagent@mvnsitehost: scp://mvnsitehost/opt/maven/sites/project/3.4-SNAPSHOT/
- Session: Connection refused
>  scp://mvnsitehost/opt/maven/sites/project/3.4-SNAPSHOT/ - Session: Disconnecting  
>  scp://mvnsitehost/opt/maven/sites/project/3.4-SNAPSHOT/ - Session: Disconnected
>  [INFO] ------------------------------------------------------------------------
>  [INFO] BUILD FAILURE
> {noformat}
> With version 2.5, I get BUILD SUCCESS:
> {noformat}
>  [INFO] --- maven-site-plugin:3.3:deploy (default-deploy) @ project ---
>  Using private key: C:\Users\BuildAgent\.ssh\id_rsa
>  scp://mvnsitehost/opt/maven/sites/project/3.4-SNAPSHOT/ - Session: Opened  
>  [INFO] Pushing D:\BuildAgent\projects\Project\Build_Snapshot\target\site
>  [INFO]    >>> to scp://mvnsitehost/opt/maven/sites/project/3.4-SNAPSHOT/./
>  Executing command: mkdir -p "/opt/maven/sites/project/3.4-SNAPSHOT/./"
>  Executing command: mkdir -p "/opt/maven/sites/project/3.4-SNAPSHOT/."
>  Executing command: scp -t "/opt/maven/sites/project/3.4-SNAPSHOT/./wagon4279752042048724778.zip"
>  Uploading: ./wagon4279752042048724778.zip to scp://mvnsitehost/opt/maven/sites/project/3.4-SNAPSHOT/
>  
>  ##############################################################################
>  Transfer finished. 316495 bytes copied in 0.031 seconds
>  Executing command: cd "/opt/maven/sites/project/3.4-SNAPSHOT/./"; unzip -q -o "wagon4279752042048724778.zip";
rm -f "wagon4279752042048724778.zip"
>  Executing command: chmod -Rf g+w,a+rX /opt/maven/sites/project/3.4-SNAPSHOT/
>  scp://mvnsitehost/opt/maven/sites/project/3.4-SNAPSHOT/ - Session: Disconnecting  
>  scp://mvnsitehost/opt/maven/sites/project/3.4-SNAPSHOT/ - Session: Disconnected
>  [INFO] ------------------------------------------------------------------------
>  [INFO] BUILD SUCCESS
> {noformat}
> So, clearly the _new behavior_ is the _Connection Refused_:
> {noformat}
>  Password for buildagent@mvnsitehost: scp://mvnsitehost/opt/maven/sites/project/3.4-SNAPSHOT/
- Session: Connection refused
> {noformat}
> (?) Could version 2.6 have broken the private key logic?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message