maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tim Stewart (JIRA)" <j...@apache.org>
Subject [jira] [Created] (MNGSITE-227) Compiler Plugin's Documentation on Compiler Args Seems Wrong
Date Tue, 07 Apr 2015 23:00:17 GMT
Tim Stewart created MNGSITE-227:
-----------------------------------

             Summary: Compiler Plugin's Documentation on Compiler Args Seems Wrong
                 Key: MNGSITE-227
                 URL: https://issues.apache.org/jira/browse/MNGSITE-227
             Project: Maven Project Web Site
          Issue Type: Bug
            Reporter: Tim Stewart
            Priority: Trivial


On this page: 

    http://maven.apache.org/plugins/maven-compiler-plugin/examples/pass-compiler-arguments.html

I'm instructed to express compilerArgs this way:

    <plugins>
      <plugin>
        <groupId>org.apache.maven.plugins</groupId>
        <artifactId>maven-compiler-plugin</artifactId>
        <version>3.3</version>
        <compilerArgs>
            <arg>-verbose</arg>
            <arg>-Xlint:all,-options,-path</arg>
          </compilerArgs>
      </plugin>
    </plugins>

When I do that I get an error:

    Unrecognised tag: 'compilerArgs' (position: START_TAG seen ...</configuration>\n
           <compilerArgs>... @21:27) 

But when I tuck the compilerArgs XML element under the configuration element, it works:

        <plugin>
          <groupId>org.apache.maven.plugins</groupId>
          <artifactId>maven-compiler-plugin</artifactId>
          <version>3.3</version>
          <configuration>
            <compilerArgs>
              <arg>-verbose</arg>
              <arg>-Xlint:all,-options,-path</arg>
            </compilerArgs>
            <source>1.8</source>
            <target>1.8</target>
          </configuration>
        </plugin>



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message