maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason van Zyl (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (WAGON-432) Maven sends duplicate User-Agent header
Date Wed, 15 Apr 2015 12:41:59 GMT

    [ https://issues.apache.org/jira/browse/WAGON-432?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14496128#comment-14496128
] 

Jason van Zyl commented on WAGON-432:
-------------------------------------

@robert, I'd like to release Maven 3.3.2 today so if you don't have time to analyze the problem
this can wait. @jan in the meantime, I suggest you take a look at https://github.com/takari/aether-connector-okhttp

I will try and make that more consumable today via extension and have it ready for tomorrow's
hangout.

> Maven sends duplicate User-Agent header
> ---------------------------------------
>
>                 Key: WAGON-432
>                 URL: https://issues.apache.org/jira/browse/WAGON-432
>             Project: Maven Wagon
>          Issue Type: Bug
>          Components: wagon-http
>    Affects Versions: 2.8
>            Reporter: Michael Osipov
>            Priority: Minor
>         Attachments: 0001-WAGON-432-do-not-set-User-Agent-header-by-default.patch, headergroup-after-setHeaders.png,
headergroup-after-setUserAgent.png, headergroup-before-execution.png, maven-3.1.1.png, maven-3.2.2.png
>
>
> Maven 3.1.1 sends only one {{User-Agent}} header, 3.2.2 sends twice. See screenshots.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message