maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Davis (JIRA)" <j...@codehaus.org>
Subject [jira] (MRESOURCES-126) Cannot escape String in a filter value
Date Wed, 04 Feb 2015 21:43:18 GMT

    [ https://jira.codehaus.org/browse/MRESOURCES-126?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=362564#comment-362564
] 

James Davis commented on MRESOURCES-126:
----------------------------------------

I don't know that this is really fixed.  Looking at the output of the test project, the filtered-with-filter
values are coming through incorrectly (pre-interpolated before filtering happens).

I would expect the with & without filter to have the same output.

I'm running maven 3.0.5 with version 2.4-2.7 of the plugin.  Version 2.3 of the plugin worked
as expected, however there are other bugs and I am unable to use 2.3.

This is a show-stopper for me

> Cannot escape String in a filter value
> --------------------------------------
>
>                 Key: MRESOURCES-126
>                 URL: https://jira.codehaus.org/browse/MRESOURCES-126
>             Project: Maven Resources Plugin
>          Issue Type: Bug
>          Components: escape string
>    Affects Versions: 2.3, 2.4, 2.4.1, 2.4.2, 2.4.3
>            Reporter: Arnaud Heritier
>            Assignee: Karl-Heinz Marbaise
>         Attachments: MRESOURCES-126-IT.patch
>
>
> I have to filter a file. The value to inject to the file is foo/${name}. Thus in my resource
I have @something@ and in my filter I would like to have something=foo/${name}
> I tried to use the escapeString option (\) and added in my filter I used : something=foo/\${name}
> I tested with various syntaxes and escape characters but it doesn't work.
> escapeString can be used to protect special characters in resources but not in filters.
In filters properties are always resolved.



--
This message was sent by Atlassian JIRA
(v6.1.6#6162)

Mime
View raw message