maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Roland Wiesemann (JIRA)" <j...@codehaus.org>
Subject [jira] (MNG-5741) maven version range not working as expected
Date Tue, 23 Dec 2014 13:12:10 GMT
Roland Wiesemann created MNG-5741:
-------------------------------------

             Summary: maven version range not working as expected
                 Key: MNG-5741
                 URL: https://jira.codehaus.org/browse/MNG-5741
             Project: Maven
          Issue Type: Bug
          Components: Dependencies
    Affects Versions: 3.2.5
         Environment: Windows / Java 7
            Reporter: Roland Wiesemann
         Attachments: example.tgz

The example is attached to this issue.
- First, install the *test:artifact 1.0.0* into the local repository
- Second, install the *test:artifact 1.1.0-SNAPSHOT* to the local repository
- Third, list the dependency tree from *use-artifact-range* which hava a dependency to *test:artifact:[1.0.0,1.1)*.
This dependency is resolving the test:artifact:1.1.0-SNAPSHOT. 
But what i expect for range [1.0.0,1.1) is to resolve *test:artifact:1.0.0*.  



--
This message was sent by Atlassian JIRA
(v6.1.6#6162)

Mime
View raw message