maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Osipov (JIRA)" <j...@codehaus.org>
Subject [jira] (MSITE-617) Variable substitution in the site url doesn't work
Date Mon, 22 Dec 2014 16:52:11 GMT

    [ https://jira.codehaus.org/browse/MSITE-617?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=359513#comment-359513
] 

Michael Osipov commented on MSITE-617:
--------------------------------------

Is this still valid?

> Variable substitution in the site url doesn't work
> --------------------------------------------------
>
>                 Key: MSITE-617
>                 URL: https://jira.codehaus.org/browse/MSITE-617
>             Project: Maven Site Plugin
>          Issue Type: Bug
>          Components: site:deploy
>    Affects Versions: 2.3
>         Environment: Windows 7 and RHEL6
>            Reporter: Claus Nielsen
>              Labels: close-pending
>
> {{site:deploy}} fails because variable substitution in the site url no longer works (it
did in version 2.2).
> The distributionManagement section in out POM looks something like this:
> {code:xml}
> <distributionManagement>
> 	<site>
> 		<id>sites</id>
> 		<name>Project Website</name>
> 		<url>scp://server/sites/${project.artifactId}/${project.version}</url>
> 	</site>
> </distributionManagement>
> {code}
> Copying the site to the above mentioned url fails with this message:
> {noformat}
> [INFO] Error uploading site
> Embedded error: Error performing commands for file transfer
> Exit code: 1 - bash: /sites/${project.artifactId}/${project.version}/../../id-of-the-artifact/0.2.8-SNAPSHOT:
bad substitution
> {noformat}
> Ie. the substitutiuon variables have not been substituted, instead the property values
have been appended to the url along with a few dots and dashes.



--
This message was sent by Atlassian JIRA
(v6.1.6#6162)

Mime
View raw message