maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Osipov (JIRA)" <j...@codehaus.org>
Subject [jira] (MIDEA-116) idea:idea doesn't generate project file with correct module dependency order
Date Tue, 25 Nov 2014 20:32:02 GMT

     [ https://jira.codehaus.org/browse/MIDEA-116?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Michael Osipov closed MIDEA-116.
--------------------------------

    Resolution: Won't Fix

Please refer to https://cwiki.apache.org/confluence/display/MAVEN/The+Great+JIRA+Cleanup+of+2014
if you're wondering why this issue was closed out.

> idea:idea doesn't generate project file with correct module dependency order
> ----------------------------------------------------------------------------
>
>                 Key: MIDEA-116
>                 URL: https://jira.codehaus.org/browse/MIDEA-116
>             Project: Maven IDEA Plugin (RETIRED)
>          Issue Type: Bug
>    Affects Versions: 2.2
>         Environment: Maven 2.0.9, IDEA 7.0.3, maven-idea-plugin 2.2-SNAPSHOT
>            Reporter: Lance Kind
>         Attachments: root.zip
>
>
> We have module A (DisinfoY-common) that requires struts 1.1 and we have module B (catprojectuLINC)
that requires struts 1.2.4.  Module B requires module A.  This works fine when the build is
done in Maven.  When we generate the Idea project file, the build dependencies are such that
struts 1.2.4 is lower than module A dependency.  
> It will build but the tests fail due to the differences between struts versions.
> We've attached the poms for further info.



--
This message was sent by Atlassian JIRA
(v6.1.6#6162)

Mime
View raw message