maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Osipov (JIRA)" <j...@codehaus.org>
Subject [jira] (MECLIPSE-426) faces-config.xml graphic editor not works
Date Tue, 25 Nov 2014 20:32:18 GMT

     [ https://jira.codehaus.org/browse/MECLIPSE-426?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Michael Osipov closed MECLIPSE-426.
-----------------------------------

    Resolution: Won't Fix

Please refer to https://cwiki.apache.org/confluence/display/MAVEN/The+Great+JIRA+Cleanup+of+2014
if you're wondering why this issue was closed out.

> faces-config.xml graphic editor not works 
> ------------------------------------------
>
>                 Key: MECLIPSE-426
>                 URL: https://jira.codehaus.org/browse/MECLIPSE-426
>             Project: Maven Eclipse Plugin
>          Issue Type: Bug
>          Components: WTP support
>    Affects Versions: 2.5.1
>         Environment: Windows-XP
>            Reporter: Marco Noto
>
> In a jsf project with structure like this:
> --src/main/java
> --src/main/resources
> I've faces-config.xml in /META-INF directory, placed under src/main/resources.  My pom.xml
include this configuration:
> {code}
> <plugin>
> 	<groupId>org.apache.maven.plugins</groupId>
> 	<artifactId>maven-eclipse-plugin</artifactId>
> 	<configuration>
> 		<wtpversion>2.0</wtpversion>
> 		<additionalProjectFacets>
> 			<jst.web>2.5</jst.web>
> 			<jst.jsf>1.2</jst.jsf>
> 			<jst.ejb>3.0</jst.ejb>
> 		</additionalProjectFacets>
> 	</configuration>
> </plugin>
> {code}
> After mvn eclipse:eclipse i've under .project directory, the file org.eclipse.wst.common.component:
> {code}
> <project-modules id="moduleCoreId" project-version="2.0">
>   <wb-module deploy-name="eos-components">
>     <wb-resource deploy-path="/" source-path="src/main/java"/>
>     <wb-resource deploy-path="/" source-path="src/main/resources"/>
>   </wb-module>
> </project-modules>
> {code}
> Now, if i open faces-config.xml with graphic editor, i've some error in eclipse log,
and i can't use it, neither i can save the file! (in the log: !MESSAGE Resource '/eos-components/src/main/java/eos-components/src/main/resources'
does not exist.)
> But if I manually invert the order of wb-resources, all works fine!
>  <wb-resource deploy-path="/" source-path="src/main/resources"/>
> <wb-resource deploy-path="/" source-path="src/main/java"/>



--
This message was sent by Atlassian JIRA
(v6.1.6#6162)

Mime
View raw message